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Tutorial - Developing websites with Kentico 8.2

Welcome to the Kentico Tutorial!

This section of the documentation explains the basics of editing content in Kentico, shows you
how to create web pages, and walks you through the development of a simple website.

We recommend that you read the tutorial from the beginning to the end, to make sure you don't
miss any step in the development process.

Before you begin

Before you dive into the tutorial, you must ensure that you have Kentico installed on your local
machine, or on a remote server, including the sample Corporate site.

If you already have Kentico installed, but don't know how to install the sample Corporate site,
see Installing new sites, then Creating new sites from templates.

Start learning Kentico

After you've installed Kentico, go to the first page of the tutorial and start learning.

Using the Kentico interface

To access the Kentico administration interface:

® Type /Admin after your site's domain into the browser address bar (for example http://mysite.com/admin)
OR
® Click the Administration link at the top of the sample Corporate site.

A logon page appears where you need to enter a username and password.

Default user name and password

The default user name is administrator. The default password is blank (no password).

It is highly recommended to change the password before publishing the website to a live server.
Once you log in, the Kentico administration interface opens. The interface is separated into applications. Each application represents a
group of related functions. Applications allow you to perform various types of tasks, configure the system, and view information.

The first page that you see after logging in is the application dashboard. The dashboard provides quick access to your most frequently
used applications. Certain application tiles in Kentico work as Live tiles. This means that they provide information that may require the user's
attention by displaying application data.
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Adding applications to the applications dashboard
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Each user in Kentico can individually configure the applications they see on their application dashboard.

1. Click the Edit dashboard icon.

2. Click on Add new application (plus sign). The application list opens.

3. Select the applications that you want to pin to the application dashboard.
4. Confirm by clicking the Edit dashboard icon again.

Predefining the application dashboard for roles
Administrators can also predefine the application dashboard for particular roles.

Moving applications on the application dashboard

To move applications on the dashboard, simply drag & drop them to a new place.

Administration interface

All parts of the administration interface share the same header, which contains the following elements:

Application list Site selector Help toolbar

Corporate Site 4 | Forms » Contact Us

Dashboard Breadcrumbs User menu

Application list Opens a list of all applications that you are allowed to access, divided by category. Use the search bar to quickly
find the application you need, or browse the categories.

You can move between applications by pressing the up and down arrows on your keyboard. Press Enter to open
the selected application.

Click Live site at the bottom of the list to open a new browser tab with the live version of the current website.

Keyboard shortcut: F2

Dashboard Returns you to the application dashboard.

Keyboard shortcut: F4
Site selector Allows you to switch between different sites if your Kentico installation contains multiple sites.

Breadcrumbs Displays the current application, and your location within the application's interface. You can click on items in the
breadcrumbs to navigate back within the interface structure.

Help toolbar Provides links to relevant pages in the main Kentico documentation (based on the current application).

Keyboard shortcut: F1
User menu Expands a menu where you can adjust the settings and preferences of your user account.

Also allows you to Sign Out of the administration interface, which takes you to the live website as an anonymous
visitor.

Tip: You can open any number of applications at the same time in different browser tabs. Right-click the application in the
dashboard or application list, and click Open link in new tab.

Managing content - The basics

In this section, you will learn the basics of editing web pages in Kentico.

Please make sure you have the sample Corporate Site installed before you continue.
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To manage the content of websites, log in to the Kentico administration interface and open the Pages application. Here you can edit the site
selected in the interface's main header.
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The Pages application consists of the following sections and features:

Content tree that represents the site map of the website. Use the tree to organize the site's structure and select specific pages.
Toolbar with Content tree actions that allow you to create, delete, copy and move pages.
View mode selector where you can switch between edit, preview and listing modes.
Editing tabs used to move between editing of page content, designing page templates (for developers), editing page fields,
configuring page properties, and monitoring of page analytics.
Culture selector that allows you to switch between different versions of multilingual websites.
* When editing pages, you can use the Text editor and Page actions to add and format page content (text, images, advanced
dynamic content).

® Available for Editable regions on the Page tab and when editing pages fields on the Form tab.

On-site editing

In addition to the main administration interface, Kentico also provides a way to edit page content directly while browsing the live website.
Authorized editors can access on-site editing mode by typing /Admin after the site's domain into the browser address bar, or by clicking the
Edit page button in the corner of pages.

i ation. The default account is administrator with blank password.

Edit page

() I Company
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» Home

All actions available in on-site editing mode can also be done through the Pages application. The on-site editing mode simply provides an
alternative way to edit websites.

This tutorial demonstrates all operations in the Pages application — we recommend first becoming familiar with the Pages application and
the general structure of website content before you use on-site editing.

Editing home page content
To modify the content of the Corporate site's home page, open the Pages application in the Kentico administration interface.

Click the Home page in the content tree.
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You can see two editable regions on the Page tab (in the Edit view mode). Editable regions have a dotted outline. Delete all content from
one of the regions and enter the following text instead:

This is my first text.

You can use the text editor toolbar at the top of the page to change the formatting of the text like this:

This is my first text.

Click Save above the editor toolbar or press CTRL+S to save the changes.

Now switch to Preview mode to see the modified version of the home page as it appears to site visitors.

Creating a simple page

Now create a new page under the website's Services section.
In the Pages application, return to Edit mode.

Click Services in the content tree.

Click New ( + ) above the content tree.
Select the type of the page you want to create under the selected page. Click the Page (menu item) option.
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5. Type System integration in the Page name field.
6. Choose the Corporate Site -> Corporate Site - Simple text template:

Save and create another
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7. Click Save to create the new page.

The page appears in the content tree. You can add content on the Page tab. Type some text in the editable regions and click Save again.
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You can change the order of pages in the content tree (and on the website). To move the System integration page to the end of the
Services section, select the page and click Move down (\“'I ) above the content tree.

Switch to Preview mode. You can now see the new page as it appears to site visitors.
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Inserting an image
Now upload and insert an image onto the System integration page created in the previous section.

1. In the Pages application, return to Edit mode.

2. Select Services -> System integration in the content tree.

3. On the Page tab, place the cursor into the main editable region, just below the text, and click Quickly insert media on the text editor
toolbar.
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4. Your browser's Choose file dialog opens. Locate a suitable image file and click Open.
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Allowing pop-ups for the website

If you are using a pop-up blocker, you may need to allow pop-up windows in your browser to see the file selection dialog.
This applies only to the administration interface (site visitors are not affected).

5. Click Save.

The image is now saved in the editable region and appears on the page. Switch to Preview mode to view the modified appearance of the
page.
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We now provide system integration services.
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Inserting a link
Now create a link between the Services page and the new System integration page.
1. In the Pages application, return to Edit mode.

2. Select Services in the content tree.
3. On the Page tab, add a bulleted list item into the second editable region and type System integration.
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4. Select the whole line and click Insert/Edit link on the text editor toolbar.
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5. The Insert link dialog opens. On the Content tab, select the Services -> System Integration page and click Save & Close.
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URL: /Kentico_8.0.0307/Services/System-integration.

Save & Close

6. Click Save on the Page tab.

The text is now marked as a link (underlined). Switch to Preview mode and click the System integration link. The new page opens in the
preview section.

Creating a news article



Now create a news article on the website.

In the Pages application, return to Edit mode.
Select News in the content tree.

Click New ( + ). The system automatically chooses the News page type (the only type allowed in the News section).
Fill in the news page fields in the editing form:
News Title: My first news
® Release Date: click Today
® News Summary: Summary text.
® News Text: News text.

PO DR

5. Click Save to create the new page.

The news page appears in the content tree (and on the website).
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When editing news pages, you use the Form tab instead of the Page tab. This means you are not editing the content of editable regions, but
rather the structured data fields of the given page. The page fields are fully customizable for every page type.

If you switch to Preview mode, you can see the data of the news page displayed on both the News page (list) and News -> My first news p
age (details).
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Page versus form

Pages have two possible types of content:

® Content stored in editable regions on the page
® Data stored in form fields

The following table compares both approaches:

Content
structure
Validation

Display

Storage

Examples
of use

Editable regions on the Page

Simple content structure.

Only supports basic validation rules for
minimum and maximum length.

The content is displayed on the page, just
like it appears in editing mode.

The content of all editable regions is
stored in a single XML field in the data of
each page.

Home page, contact page.

Generally: pages with simply structured
or unstructured text-based content.

The editable regions are usually used for
pages of the Page (menu item) type.

Site development overview

Kentico provides two basic development models. You can choose the approach that best suits your needs:

Portal
engine

ASPX
templates

Form

Complex content structure, typed data, such as text, date-time values, numbers,
files etc.

Customizable validation rules, including regular expressions and custom form
controls with custom validation code.

You need to use listing web parts or controls to display the content using
transformations.

The content is stored in a separate database table for the given page type. Each
field has its own column. The data can be easily modified using SQL queries or
the APL.

News, product specification, event details, job openings, etc.

Generally: pages with structured content where you need to separate content
from design and keep the content in its original data type.

Form-based content is usually used for pages types such as News, Product,
Article, Blog.

Recommended for most developers. Does not require programming and using Visual Studio. You can build websites using
page templates and web parts in a browser-based user interface.

To learn the basics of the portal engine, see Creating pages using the portal engine, then Walkthrough - Creating a new site

using the Portal engine

Can be chosen by ASP.NET developers who prefer to create websites using standard ASP.NET architecture and standard
development tools, such as Visual Studio. You need to be familiar with ASP.NET development and have at least basic

programming knowledge of C# or VB.NET.

To learn the basics of ASPX template development, see Creating pages using ASPX templates, then Walkthrough - Creating

a new site using ASPX templates.

Both approaches are fully supported and provide the same level of flexibility and extensibility. We recommend using the portal engine, but if
you are an advanced .NET developer or wish to integrate existing functionality built on standard ASP.NET architecture, you may want to use
ASPX templates.

It is also possible to create websites or specific pages using the Model-View-Controller architectural pattern (based on the
ASP.NET MVC framework), but this is beyond the scope of this basic tutorial.

If you're not sure which development model is best for you, see Choosing the right development model.

Creating pages using the portal engine

The Kentico Portal engine allows you to create dynamic web pages without any programming knowledge. With the Portal engine, you don't
need to use Visual Studio or any other web development tool. Instead, you create reusable page templates directly in your web browser.

What you need to use the Kentico Portal engine:

® basic knowledge of HTML and CSS to be able to create page layouts
® a supported web browser

Start by learning what Page templates are and how you can use them.

Page templates
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The Kentico portal engine provides a highly flexible and extensible framework that allows you to build complex dynamic websites using
built-in or custom web parts.

What is a page template?

Every web page is based on a page template. The page template can be specific for a single page (so called "ad hoc" page template) or
re-used for any number of pages. The following picture shows examples of pages that use the same page template.

Pages Created Using the Page Template

(3 1Mcompany

Empty Page Template

Network Administration

Parrs Ruapies notde omer Pomsceay

The pages have different content, but use the same header, menu content structure, and footer — they are based on the same page
template. Templates allow you to quickly create multiple pages with the same design.

What does a page template consist of?

Portal engine page templates are a combination of a page layout (ASCX or HTML code) and web parts. The following figure illustrates the
structure of page templates and how they are used to display pages.



Page layout with web part zones

<tabler
<tr:
<td>
<cms :CMSWebPartZone runat="server" ZonelD="zoneleft" />
<ftd> —_
<td> -
<cms :CMSWebPartZone runat="server" ZonelD="zoneRight" />
</td>
<ftry
</table>
+

Web parts and their configuration

Web part 1

Page template = layout + web parts

Web part 1

Web part 3
+

Content

Resulting page (page template + content)



The page layout is a piece of fully customizable HTML code that defines the design of the page and contains web part zones. The web part

zones represent areas where designers can place web parts. The web parts display page content or provide functionality, such as input
forms. The layout and the web parts together define the page template.

When you add page specific content to the page template, you get the final page.

Modifying page templates

Now you will learn how to work with the layouts of portal engine page templates.

1. Open the Pages application.
2. Select the Home page in the content tree.
3. Switch to the Design tab.

Here you can see the the structure of the home page template. The page header and main menu are inherited from the root page. The
"active" area, designated by a green header, contains the orange web part zones and instances of web parts.

Active page
template

Web part

Web part zone

Learn more

Inherited content

Your shopping cart is e
Text size:w m B

O IT Company S—
Home

Products News ‘Community Services Company Media

= Top content text
-

. Ohlimited Website Possibilities!
ﬂis_isasarmleud_;siecreﬁedwmkqntuIorASP,NET,Them@slemnsiﬂso{ i

multiple
sections demonsirating the powerful capabilities of the system. You can use it as a starter kit for
development of your own website and to leam Kentico.

pIrrIIrs,

= Actions zone

= Widget actions
= @ Mobile redirection

i Featured procuct vweiwuinie w the sample Corporate Site

If you are new to Kentico , please read the following information before you start ex:
There are currently no products

(Editor) Left zone = Main zone (Editor) Right zone
(Editor) Random products = Content text

(Editor) Scrolling news.
Latest news

re

Expectations

The page is based on the page template Corporate Site - Home page. The page template consists of web parts that are placed inside web
part zones. The placement of the web part zones is specified by the template's page layout.

To modify the layout of the template, click the menu icon (=) in the green header of the active page template and select Edit layout in the
menu.
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Add CSS styles

Save & Close

The page layout consists of basic HTML (or ASPX) code. It contains CMSWebPartZone controls, which define the web part zones on the

template. Each zone control must have a unique ID. You can format the layout using any type of HTML code — it's up to you whether you
use tables or a CSSbased layout.

Working with the layout code

You can use the selector above the code editor to quickly Insert web part zones and other advanced layout elements.

By clicking Preview in the header of the editing dialog, you can edit the layout code side-by-side with a preview of how the changes affect
the live site version of the page.

Access control

Only users who have the Global administrator Privilege level or have the Design web site permission assigned for the Design m
odule can open pages on the Design tab and edit page layouts. This functionality cannot be accessed by regular content editors.

Modifying the home page structure

Now you will learn how to define the content of a page template's web part zones. Specifically, we will add a web part that allows visitors to
rate content onto the template used by the Home page.



1. Make sure you are in the Edit mode of the Pages application.
2. Select Home in the content tree.
3. Open the Design tab.

You can insert web parts using the toolbar displayed on the right side of the tab. For example, type the word "content" into the search text
box at the top of the toolbar. This limits the listed web parts to those that have the word "content" in their name.

Page  Design = Form  Properties s Analytics 4 | Web part content
= Actions zone All web parts o
= Widget actions

:l content]

Mobile redirect .
@ Mobile redirection Content rating
= (Editor) Left zone = emams (i i)

Content ratin:
Used to enable rating of page content. * g

(Editor) Random products = Content text B . _
Feawredproduct ~ vverewine w the sample Corporate Site Latest news E-commerce
; . N N ™ Shopping cart content
fyou are new fo Kentico, please read the following information before you start
Community Website Section

03/28/2014 As a result of our Listings and viewers
continuous effort to imprave our
Default user name and password services, we have recently Wl Content slider

introduced the Community section
. of our website. It is a place where e .
You can sign in fo the system's administration interface using the link in the heat |, can B Notifications

pice $1517.14 fothefo ress

http://<domain>/Admin

@ Content subscription

Hover over the Content rating web part, hold down the mouse button and drag it from the toolbar to the bottom of the Actions zone, below
the Mobile redirection web part. After you drop the web part into the zone, the Web part properties dialog opens.

Scroll down to the Web part container property and select Corporate Site - List box content as the value.

Web part properties (Content rating) * o X

General

Anonymous users can rate: b v
Check if user rated: P [+
Hide to unauthorized users: p

Message after rating: p | Thank you for your rating.

Web part container

Web part container: b | Corporate site - List box content A Edit New

Container title: p
Container CSS class: b

Container custom content: p

Hide container on subpages: p
HTML Envelope

v| Refresh content Apply Cancel Save & Close

Click Save & Close to save the changes. If you ever wish to adjust the properties of a web part at a later point, double-click the web part on
the Design tab to open the Web part properties dialog again.

Switch to Preview mode to see how the new web part affects the appearance of the Home page.
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» Home

Discover Unlimited Website Possil
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Learn more
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Current rating: 4 (1 ratings)

Welcome to the

\"" Featured product

Return to Edit mode and view the Home page on the Design tab again. The system provides an alternative way of adding web parts if you
do not wish to use the toolbar.

Right-click the header of the zone where you want to insert the web part and select Add new web part in the menu.

The Select web part dialog opens, where you can look through the catalog of all available web parts. For example, the previously used Cont
ent rating web part is in the Content rating category.



Select web part

Recently used web parts
©  All web parts
Abuse report

Articles

Chat

© Community
Content rating
Custom tables

© Data sources
Device profiles
Document library

© E-commerce
Email marketing
Events & booking
Filters
Forms

© Fforums

Full-text search

© General

(-]

Attachments
Banner management

© Blogs Content rating

Used to enable rating of page content.

Search in description

Close the dialog, since there is no reason to add the web part again.

Both ways of adding web parts achieve the same result. When instructed to add a web part to a page template in the remaining parts of this

tutorial, you can choose whichever method you prefer — either the toolbar or the zone action buttons.

Developing custom web parts

You are not limited to using the default set of Kentico web parts. You can find web parts created by other developers at the Kentico
Marketplace or develop your own web parts.

Testing changes without switching the view mode

You can quickly test the changes you make to the structure of the website by opening or refreshing the given page in a different
browser. Note that the view mode changes if you use two tabs of the same browser.

Multiple tabs can however be useful for switching between different application in the administration interface.

Customizing pages using widgets

In the Pages application, view the Home page on the Design tab. The Left zone and Right zone zones have the (Editor) prefix before their

name.
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vecicuimne w the sample Corporate Site

fyou are new to Kentico, please read the following information before you start exploring the website:

Default user name and password

~| Web part col

(E (Editor) Right zone ]

You can sign in to the system's administration interface using the link in the header of the page or by going
to the following address

= (Editor) Scrolling news

Latest news

Community Website Section
03/28/20 a result of our
continuous effort to improve our
services, we have recently
introduced the Community section
of our website. It is a place where
you can

This identifies zones that contain widgets rather than web parts. Widgets are components placed into page template zones just like web
parts, but they provide the option of page customization for various kinds of website users, not just administrators and designers. The two
widget zones on the Home page are configured to allow customization by page editors. You can manage the content of the zones when

editing pages on the Page tab of the Pages application.

Switch over to the Page tab, click the menu icon (=) in the corner of one of the widget zones and then click Add new widget in the menu.

The Select widget dialog opens. The dialog is similar to the web part selection dialog, but with less items available. This is because every

widget is based on an existing web part. Select the Content -> Latest blog posts widget and click Select.

Select widget o X

Recently used widgets

© Al widgets
Banner management
Categories
Community
Content
Corporate Site
Dashboard
Document library
Forms & Surveys
Forums
General

© Intranet Portal

Layouts
Maps
Media & services
Navigation
Newsletters
On-line Marketing
Reporting
Syndication

Text

Search in description

"— =
Has w1 L1
—

Article List Attachment image Blog comments Content rating Event calendar

gallery

i N |«

Latest blog posts

Latest news Random products Reporting Scrolling news

Displays a list of blog post documents that were most recently added to the specified section of the website.

Enter the following values into the widget's properties:

® Widget container: Black box
® Widget container title: Latest blog posts

Leave the remaining properties in their default state and click Save & Close.

The widget appears on the page, but is NOT permanently saved yet. When working with widgets on the Page tab, you need to

click Save again on the page itself to confirm changes.

After you save the page, switch to Preview mode using the main toolbar to view the modified design of the home page. As you can see,

content editors can alter pages with widget zones.
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Latest blog posts
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Remote Management
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Examples
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Now we will try out a different type of widget zone. Switch back to Edit mode and the Design tab. Expand the menu (E ) of the Right zone
and click Configure in the menu.

Set the Widget zone type property to User personalization and click Save & Close. The zone is now editable by registered users directly
on the live site.

Note: The system removes the content of a zone when you change the zone type.

View the live site (click the Kentico logo on the header to open the application list and click Live site). On the Home page, hover over the
location of the right zone and click Add new widget.

e L4

= Featredproduct ~ YV€lcome to the sample Corporate Site @:
-~

If you are new to Kentico , please read the following information before you start exploring the website:

There are currently no products.
Default user name and password

w Newsletter

First Name:

You can sign in to the system's administration interface using the link in the header of the page or by going to
the following address:

http:ii<domain>/Admin
Last Name

On the logon page that appears, use the following default credentials:
E-mail
User name: administrator

Password: leave the password blank

Select the Content -> Latest news widget and click Select. In the properties dialog, leave the default values and click Save & Close.
Changes made to widgets in user zones apply immediately — users on the live site do not need to save the page manually.




Welcome to the sample Corporate Site Latestnews o B i

Company Growth Exceeds
If you are new to Kentico , please read the following information before you start exploring the website —"75:;7";553&“”5
Qur company growth has reached
astonishing 256% in the last
financial year. It is not only thanks
to the excellent and devoted work
of our employees, but mainly

Default user name and password

Youc ign in to the system's administration interface using the link in the header of the page or by going to thanks to you, our faithful

the fc ng address customers. Therefore, we would
like to thank you for your loyalty

http://<domain>/Admin and state a promise that we will
keep to the high standard of

On the logon page that appears, use the following default credentials PfUd:C‘S and senices we currently
provide

The content of user widget zones does not affect the global appearance of the page. Each user can only see their own personalized version
of the user zones on pages. Log off the website and log in as a different user (enter the username Andy with a blank password). View the
home page on the live site, and you can see that the zone is displaying the default content (empty in this case). The widget previously added
under the administrator account is not visible. Every user can choose their own content for the zone from the available selection of widgets.

Log off and sign back in as the global administrator (username administrator).

Managing widgets on the Design tab

You can add and configure widgets of all types directly on the Design tab of the Pages application. This sets the default content
of widget zones for the template. The content displayed on pages does NOT match the default content once users make changes
to the widget zones.

Creating new page templates

Now you will learn how to create a new page from scratch without using a predefined page template. We will create a new About Us page
with two columns that contain editable regions.

. Open the Pages application.

. Select the root in the content tree and click New ( + ).

. Choose the Page (menu item) page type.

. Type About us as the Page name, choose to Create a blank page with layout and select the Two columns layout. Make sure
that the Copy this layout to my page template box is checked — ensures that your page template uses a separate copy of the
predefined layout without changing other pages.
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Page name: | About Us

Use existing page template Use parent page template @ Create a blank page with layout Create 3 blank page

— HE ] — —
— I —
= HE | ] — =
— _ —

Full page Grid 2x2 cells Grid 3x2 cells Rows Simple
Three columns Three columns - Three columns - Three columns - Two columns
20/60/20 25/50/25 33/33/33
Two columns - Two columns - Two columns - Two columns -
20/80 30/70 70/30 80/20

Two column layout using CSS

C/ Copy this layout to my page template)

5. Click Save to create the new page. You cannot edit the page yet, because there are not editable regions on the new template.
6. Switch to the Design tab and add the Editable image web part to zoneB.
7. Configure (double-click) the web part and set the following properties:

® Web part control ID: Leftimage

® Image title: Left image



8. Click Save & Close.
9. Add the Editable text web part to zoneC. Configure the web part and set the following values:
® Web part control ID: HeaderText
® Editable region title: Header
® Editable region type: Text box
® Content before: <hl>
® Content after: </h1>
10. Add another Editable text web part to zoneC with the following properties:
® Web part control ID: MainText
Editable region title: Main text
Editable region type: HTML Editor
Editable region height: 400

Result

Switch to the Page tab. The page now contains editable regions.
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You can type in text content and choose an image using the Select button. Click Save and view the page in Preview mode.

Sign in to Administration. The default account is administrator with blank password.

O IT Company

t Us Home Products News Community Services Company

» About Us

About us

Our company was founded in...

Re-using page templates

The previous tutorial page described how to create a new page with its own page-specific template. This type of page template is called an a
d-hoc page template.

Now you will learn how to convert the ad-hoc template into a reusable page template, which can be used to create any number of pages with
the same general layout, but different content.

1. Open the Pages application in Edit mode.
2. Select the About Us page in the content tree.
3. Switch to the Properties -> Template tab.



Page Design Form Template 4 Analytics 4

Template

Inherit from parent

® Use own page template
Ad-hoc: About Us Select
Save as new template
Edit template properties

Page nesting

® Use page template settings (Only the nearest master page)
Mone
Only the nearest master page

Specific ancestor pages

4. Click Save as new template and enter the following values:

®* Template display name: Left image with text on the right

®* Template category: Templates with editable regions

® Template description: Two columns with an image on the left and text on the right.
® Assign to the current page: Yes (leave the box checked)

5. Save & Close.

Result

If you try to add a new page now, the Left image with text on the right page template is available among the offered options in the Templates
with editable regions category. You can create another page with the same structure as the About Us page.

Because the Assign to the current page option was checked, the system also automatically assigns the template to the current page
instead of the previous ad-hoc template.

Important: When you modify a re-usable page template, the changes affects all pages that use the template.

When you delete a page which uses an ad-hoc page template, the template is automatically deleted together with the page.

Content inheritance

Inheritance (page nesting) allows you to maintain a consistent design throughout the website and manage content shared by multiple pages
in a single location. The portal engine implements inheritance by nesting subpages inside the content of ancestor pages on higher levels of
the content tree.

What are ancestor pages?

Ancestors include all pages under which a given page is stored, from the root of the site's content tree down to the page's direct
parent.

For example, the /Company/Offices/London Office page has the following ancestors:

® \Website root page
® /Company



® /Company/Offices

Website root (master page) without nested content
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Discover Unlimited Website Possibilities!

This is a sample website created with Kentico for ASP NET. The website consists of multiple sections demonstrating the powerful capabilities of the system. You canuseitas a
starter kit for development of your own website and to learn Kentico

=

", Featuredproduct  Welcome to the sample Corporate Site Latest news
There are currently no products If you are new to Kentico , please read the following information before you start exploring the website: Apple iPad 2 In Stock

02/0612014 Today, we have good
news for al fans of the awesome ]

Page placeholder

Note how the pages are structured in the content tree: the root (master page) is the parent of the Home page, which is loaded inside the
master page. You can perform nesting recursively at any level of the content tree. A necessary component for page nesting is the Page
placeholder web part. This web part must be placed on the master page, and specifies where the system inserts the underlying pages. The
Page placeholder on the Corporate Site root loads the sub-pages between the main menu and footer.
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Configuring content inheritance
When using page nesting, you may need to hide parts of the parent page. Kentico provides several ways to achieve this goal:

® Using the "Page nesting" settings
® Using the "Hide on subpages" web part property
® Using the "Show for page types" web part property

Using the "Page nesting" settings

. Open the Pages application.
Select the /News page and open the Properties -> Template tab.

. Click Edit template properties.
Set the Page nesting value to None. This means that the page does not use any nesting, so the content from the site's root (master

page) is not visible.
5. Click Save to confirm the changes.
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General

Layout
; Template display name:™ Corporate Site - Mews
Device layouts
Template code name™ Corporate.SiteNews
Header P & o
pages Category: Corporate Site en
Versions Template description:
4
Thumbnail: Font icon dass M
icon-I-list-img-article
Clone as ad-hoc for new pages:
Template type: Portal page B

Master template:

Page nesting: All ancestor pages
®) MNone
Only the nearest master page

Specific content tree levels

When you close the dialog and view the News page in Preview mode or on the live site, the page does not display the shared content from
the master page.



News

[This is a sample section for publishing of news on the website. Various types of news related to the topic of the website or the
'website itself can be puslished in this section. News are standard Kentico CMS documents of the News document type. They
can be added to this section by content editors via the Pages application in the administration interface. Created news can be
scheduled to be published on a specified future date and time and you can also set up a news approval process that news
need to go through before they are published

News List &
MNews title:
Company Gro
|l Our company growth has reached astonishing 256% in the last financial year. It is not only thanks to the
hr excellent and devoted work of our employees. but mainly thanks to you, our faithful customers. Therefore, we

would like to thank you for your loyalty and state a promise that we will keep to the high standard of products
and services we currently provide

Global Administrator | 6/17/2014 12:00:00 AM

To return the page to its original state, edit the template again and set the Page nesting value to Only the nearest master page.

You can also set the page nesting for individual pages using the Properties -> Template tab. The nesting settings you configure for pages
override the settings of the assigned page template.

Using the "Hide on subpages" web part property

Every web part has a property called Hide on subpages.

1. In the Pages application, edit a parent page on the Design tab.
2. Configure (double-click) the web part you want to hide.

3. Expand the Visibility category, and enable Hide on subpages.
4. Click Save & Close.

The web part is hidden on all pages where it is inherited from an ancestor page.

Using the "Show for page types" web part property

The Show for page types web part property allows you to limit which page types display the given web part. To see how this works:

1. In the Pages application, select /Community/Blogs/Andrew Jones Blog in the content tree.
2. On the Design tab, configure (double-click) the Header text, Description text or Blogs filter web part.

All of the web parts have the Show for page types property set to CMS.BlogMonth;CMS.Blog (in the Visibility category). This
means that the web parts only appear on blog month and blog pages, not on individual blog posts, which are stored under blog
months.

3. Click Cancel.



Web part properties (Page name filter)

General Layout

Default

Web part control ID:* p | wBF

Web part title: b | Blogs filter
= visibility
Visible: b |~

Hide on subpages: »

Show for page types: b | CMS5.BlogMonth:CMS5.Blog Select Clear

Display to roles: » Select roles Clear

Switch to Preview mode. The header text, description text and filter are all displayed above the repeater displaying blog posts.

Sign in to Admini: ion. The default account is administrator with blank password
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About Us Home Products News Community Services Company Media

» Community > Blogs » Andrew Jones Blog

'D Blogs Events -. Forums e Wiki

&\ndrew Jones Blog

Hi, my name is Andrew Jones and | am the head of web development in our company. | decided to start this blog in order to share the most
nteresting remarks and ideas that | come across during my day-to-day work. | will share all sorts of interesting information related to activities o
pur company and to web development in general. | believe that it will be interesting reading for all our customers, partners and all other
ndividuals interested in web development. And of course, you can post comments on each blog post in case that you want to share your
bpinion, have something to add or if you want to raise a discussion related to a post's topic

Blog post name:
J
< Remote Management
& V= |
@J In this blog post. | will share some remarks regarding communication between our former New York Office and the newly setup
London Office

Andrew Jones | 3/23/2014 3:12:26 PM | 2 comments

Click a specific blog post. The web parts are not visible, because the CMS.BlogPost is not among the allowed page types.

ymmunity ® Blogs » Andrew Jones Blog » March 2014 » Expanding to Europe

Events -. Forums s Wiki

.- Blogs

Expanding to Europe

In this blog post, | will try to share some of my impressions of the recent expansion of our operations to the Old Continent.

As you could already get to know from the News section, we have recently opened a new office in
Londen, United Kingdom_ The office has already started its operation and first projects are to be
delivered soon, so | finally found some time to share my impressions from its setup

Adding custom code to your website

The easiest way to insert custom code into a portal engine based website is using standard ASCX user controls. If you are not familiar with
Visual Studio development, you can skip this page.



Current time example

In this example, we will create a simple user control (ASCX) using Visual Studio and integrate it into the Home page.

1. Open the website project using the WebSite.sIn or WebApp.sin file, which is located in the folder where you installed the website.

2. Create a Web User Control and set its name to GetTime.ascx.You can set the programming language option to either Visual C# or
Visual Basic.

3. Drag the following ASP.NET controls onto the page from the toolbox and set their properties:

® Button control:
* |D: Buttonl
® Text: Gettime
® Label control:
® |D: Labell
® Text: <clear the value>

4. Switch to the Design view and double-click the Show current time button.
® The user control's code behind file opens and creates the Button1_Click method.

5. Enter the following code into the Button1_Click method:

Label 1. Text = DateTi ne. Now. ToString();

6. Save the user control's files.

The code ensures that the label displays the current date and time when the button is clicked. You do not need to build the project — user
controls are compiled at run time.

Adding the user control onto the page

. Log in to the Kentico administration interface and open the Pages application.

. Select the Home page and switch to the Design tab.

. Add a User control web part to the Main zone.

. Enter the following value into the web part's User control virtual path property: ~/GetTime.ascx. The ~ character represents the
root of your web application.

5. Click Save & Close.
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Switch to Preview mode to see the user control's output on the page. When you click the Get time button, the current date and time appears
next to the button.
User controls versus web parts

You can also insert custom code onto portal pages by creating your own web parts. Web parts are very similar to user controls, but
with a built-in portal engine configuration interface. We recommend building web parts if you need easily re-usable and
configurable user controls.

For more information, see Developing web parts in the main documentation.

Walkthrough - Creating a new site using the Portal engine

This part of the tutorial guides you through the creation of a simple website. You will learn how to:

® Define site structure and design
® Create your own page templates and pages

The tutorial uses a static website template that is similar to what a developer gets from a graphic designer.

Click to download the sample web template

The template consists of the home.htm file, a styles folder and an app_themes folder with images.


https://docs.kentico.com/display/K82/Developing+web+parts
https://docs.kentico.com/download/attachments/58339547/SampleWebTemplate.zip?version=1&modificationDate=1394196859133&api=v2

Our Business, Inc.

Home Page 1

Welcome to Our Business, Inc. Web Site

This is a sgample website design that will help you understand how to convert a site
template info a master page in Kentico.

How to convert a website template into a master page

The procedure is simple:

1. Create a new site.

2. Open the Pages application.

3. Click the root document in the content free_ which is the master page.

4. Switch to the Design fab, right-click the green template header and click Edit
layout in the menu.

. Copy the HTML code from the static page inte the layout.

. Inzert web part zone fags whereever you want to dizplay dynamic content,
such as editable regions, menus, news, eic.

7. Click Save & Close.

3. Add web parts with the required content into the web part zones.

9. Remember to place one Page placeholder web part onto the master page
template, so you can nest sub-pages.

. Open the C55 stylesheets application, and copy the required G55 styles
into your website's stylesheet.

@

‘You're done. Now you can continue by creating sub-pages.

Our Business, Inc.
127 One Business Way
Loz Angeles, CA

phone: (800} 111 1111
fax: (800) 111 1111

Creating a new website using the New site wizard

The following pages assume that you have previously installed the sample Corporate Site (running on the localhost domain). Leave the

existing website and add a new site running under the 127.0.0.1 domain.

Multiple sites and Visual Studio's built-in web server

If you are using the built-in web server in Visual Studio instead of IIS, you need to Stop ( | ) the Corporate Site site in the Sites
application. The built-in web server doesn't support any domain other than localhost, so you need to use the localhost domain ag

ain for the new site.

1. Log in to the Kentico administration interface as administrator and open the Sites application.

2. Click New site wizard.

Corporate Site Sites
| Mew site wizard I Import site or objects View export history

Actions

[ CH N

Site name & Status Main domain Documents Default culture

Corparate Site Running localhost 572 B3 English - United States

Items perpage | 25 ¥




The New site wizard opens.
3. Select Create a new site using a wizard and click Next.
4. Enter the following details for the website:

Site display name: My website

Site code name: mysite

Domain name: 127.0.0.1 (if you are using Visual Studio built-in web server, set the Domain name value to localhost)

Site culture: English - United States (the default culture determines how the website displays date, time and numeric values based
on the different culture-specific format)

Click Next.

5. The third step of the wizard allows you to select which objects the system imports into the new site. Do not change anything and click Ne
xt.

The fourth step displays the progress of the object import.

6. Choose a master page template for the website. You can change it later at any time. For now, select the Blank master page.

Step50f6  Select master page

The master page defines the layout of the main menu, logo and content placeholders. You can change it at any time later.

Blank master page
Generic default page template.
Corporate Site - Master page

Corporate Site - Mobile development - CMSConditionalLayout (Master)

Corporate Site - Mobile development - CMSDevicelLayout (Master)

Click Next. This concludes the initial process of creating the website.
7. Click Edit your new website.

The system opens a new tab with the Kentico administration interface using the 127.0.0.1 domain. You need to sign in again (user name ad
ministrator, blank password) since authentication is not shared over different domains by default.

Creating a CSS stylesheet

Before you start editing your new website, prepare a hew CSS stylesheet based on the styles and images of the sample website template.

1. Open the CSS stylesheets application.
2. Click New CSS stylesheet.
3. Enter the following values:
® Display name: My site stylesheet
® Code name: MySite
® Code: copy and paste all CSS code from the Sample web template - SampleWebTemplate\Styles\main.css


https://docs.kentico.com/download/attachments/58339547/SampleWebTemplate.zip?version=1&modificationDate=1394196859133&api=v2

General
Display name:™ My site stylesheet
Code name:* MySite 9
v| assign to website My website
Code
/* -——— News page ———— %/

.NewsTitle

{* ———— Drop-down menu —-——— */

.subCMSMenultem, .subCMSMenultemMouseCver, .subCMSMenultemMouseDown, .subCMSMenultemMouseUp, .subCMSMenuH

EEE | > | A @ |

Click Save.
Switch to the Sites tab and assign the stylesheet to My website.

. Open the Sites application and edit ( s ) My website.
. On the General tab, select My site stylesheet as the Site CSS stylesheet.



General

Site display name:*
Site code name:”
Site domain name:*

Site description:

Cultures

Default content culture:

Visitor culture:

Style sheets

Site C55 stylesheet:

My website

mysite

127.0.0.1

Sample blank web site

English - United States

(Automatic)

My site stylesheet

Editor CSS stylesheet:

(site stylesheet)

Change
Edit MNew
Edit MNew

8. Click Save. This ensures that all pages of your new website load the appropriate stylesheet.
9. Copy the SampleWebTemplate\app_themes\MySite folder to the CMS\App_Themes folder in your web project (c:\inetpub\wwwro

ot\Kentico by default).

The folder contains graphics for the website template. The App_Themes location ensures that the images are exported as part of the website
if you decide to move the website in the future. The folder under App_Themes must have the same name as the code name of the CSS

stylesheet: MySite.

CSS stylesheet URL and relative paths

The image paths in the sample CSS stylesheet already match the target folders in your new website. In real-world scenarios, you
will need to adjust the paths manually. The URLs of images in the CSS stylesheets are always relative to the location of the

web project.

The URL of the CSS stylesheet is:

<web project>/CMSPages/GetResource.ashx?stylesheetname=MySite

which means that you need to link to files in the App_Themes folder like in the example below:

/app_themes/mysite/images/imagename.gif



Developing the master page

The master page allows you to define content that can be shared by all pages on the website, such as a header, navigation menu and footer.
The site's root page represents the main master page.

1. Open the Pages application.
2. Select the root of the content tree (My website).
3. Switch to the Design tab. The default design uses a blank page template with two web part zones.

Preview Listing Page Design Form Master page Properties 4 Analytics a4 +| Web part content

+ i & B A v O / - page template: Blank master page

in T
My website [ zoneTop

zoneContent

= [ pageplaceholder

4. Right-click the pageplaceholder web part in the bottom zone and select Remove. The Page placeholder is an important master
page component, but you will add it again once the final page layout of the master page is prepared.

5. Click the menu icon (== ) in the green page template header and select Edit layout in the menu.

Delete the default layout content.

7. Open the sample home.htm file (from the Sample web template) and copy the HTML code from inside the <body>...</body> tags.
Paste this code into the page layout editor.

o

Page template layout properties » o X
(=]
Layout element: Web part zone v Insert
Layout type: ASCX M

ortalCon CMSAbstractlayout”
13" Namespaci iS.PortalControls™

"cms" %>

<div class="MainDiv">

<!-- main menu -->

<div cl nMenu">

llzpacing="2" cellpadding="2" border="0":

hlightedMenultem">Home</td>
tem">Page 1</td>

<!-- main content ——>

<table style="width:100%;height:500px;border: Opx">
S H >a 88| F|F| @ ss |/ o8
Add CSS styles

Save & Close

Using CSS-based layout instead of tables

If you prefer using a CSS-based layout, you can modify the HTML code here and replace the tables with other elements
(<div>, <span>, etc.).


https://docs.kentico.com/download/attachments/58339547/SampleWebTemplate.zip?version=1&modificationDate=1394196859133&api=v2

8. Click Save & Close.
9. Switch to the Page tab.

Here you can view the new website design. For now, all content is static and determined by the page layout code.

m Preview | Listing Page  Design  Form  Masterpage  Properties s Analytics «

+ @ B BE A v O m Spell check Apply workflow
W My website L]
r Business, Inc.
Home Page 1
Welcome to Our Business, Inc. Web Site Our Business, nc
127 One Business Way
This is a sample website design that wil help you understand how to convert a site. Los Angeles, CA
template nto & master page in Kentico
phone: (800} 111 1111
How to convert a website template into a master page fax: (800) 1111111

The procedure is simple:

1. Create a new site.

2. Open ne Pages appicaton

3. Click the root document in the content tree, which is the master page.

4 Swich 1 the Design tap, rght.cc the green template header and cick Edit
layout in the menu.

5. Copy the HTINL cade fromthe stti page to the syout.

&. Insert web part zone tags whereever you want to display dynamic content,
Such as edtabl regons, menus, news, etc

7. Click Save & Close.

3 Adt web parts wi the required content nto the web part 20nes.

9. Remember to place one Page placeholder web part onto the master page

P {emplate, 50 you can nest sub-pages.

10. Open the €SS styleshects appication, and copy the required CSS styles
| into your website's stylesheet.
You're done. Now you can continue by creating sub-pages.

Adding web part zones

To make the master page editable through the portal engine, you need to replace the static HTML code in the page layout with web part
zones.

In the Pages application, edit your site's root page on the Design tab.

. Click the menu icon (=) in the green page template header and select Edit layout in the menu.

Locate the <!-- main menu --> section in the layout code and delete the entire table inside the <div class="MainMenu"> element.
Place your cursor inside the <div class="MainMenu"> element and click Insert above the editor. This adds a web part zone control

into the layout.
5. Change the value of the web part zone's ZonelD property to zoneMenu. The main menu section should now match the following

code:

rpON P

<l-- main nmenu -->
<di v cl ass="Mai nMenu" >

<cns: CMSWebPart Zone Zonel D="zoneMenu" runat ="server" />
</ di v>

6. Delete the entire content section between the <!-- main content --> and <!-- /main content --> lines and Insert another web part

zone instead.
7. Set the second web part zone's ZonelD to zoneMain:

<l-- main content -->
<cns: CMSWebPart Zone Zonel D="zoneMai n" runat ="server" />
<l-- /main content -->

8. Click Save & Close.

The Design tab now shows the new layout with web part zones.



Page

Our Business, Inc.

zoneMenu

zoneMain

Design Form Master page Properties 4 Analytics 4

Previewing the layout

By clicking the Preview button in the header of the layout editing dialog, you can modify the code side-by-side with a preview of

how the changes affect the live site version of the page.

Page template layout properties

| ] I I = / Select G
.
Save
«div class="MainDiv"> Our BUSIness’ |nC.
<!-- logo —->
<br />
<div class="Logo">
&nbsp;
</div>
<!-- main menu —->
<div class="MainMenu">
<cms:CMSWebPartZone ZoneID="zoneMenu" runat="server" />

</div>
<!-- main content -->

<cms:CMSWebPartZone ZoneID="zoneMain" runat="server" />
<!-- /main content -->
<!=-= footer -->

<div class="Footer">

This is a sample Kentico website

</div>

</div>
EH »>al a8 =2 o 1 | /22
Save & Close

Master page tab

The Master page tab of pages with a master template allows you to add a custom DOCTYPE directive, custom HEAD section

elements and custom BODY attributes.

Creating the main menu
Now we will add a dynamic menu to the master page.

1
2
3
4

. In the Pages application, select the root page (My website).

. Open the Design tab.

. Add the Drop-down menu web part to the zoneMenu zone.

. Set the following properties of the web part (in the Design section):

Property  Value Description

CSSPrefix

;sub

Allows you to add prefixes before the names of the CSS classes applied to the menu. The ;sub value
uses unmodified class names for the main (first) menu level and the sub prefix for the second level and
all other sub-levels.



Layout Horizontal =~ Arranges the menu items horizontally.

5. Click Save & Close.

The web part appears in the zone on the Design tab.

Page Design Form Master page Properties 4 Analytics 4 Web part content
| All web parts v
| Drop il |

Our Business, Inc.

Localization

= cmsmenu Navigation
Eewn o P

This is a sample Kentico website

The menu will display the child pages after you create them under the website root.

Adding the page placeholder

Add a Page placeholder web part that ensures the loading of child pages (such as Home or News) inside the master template.

1. In the Pages application, select the root page (My website).
2. Open the Design tab.
3. Add the Page placeholder web part to zoneMain.

You do not need to make any changes to the page placeholder properties.

Page Design Form Master page Properties 4 Analytics a4 ‘Web part content
| All web parts v
. | place il |
Our Business, Inc.
General

= [{ pageplaceholder

This is a sample Kentico website

Developing the Home page

To create the Home page of the tutorial website.

. In the Pages application, select the root page (My website).

1
2. Click New (F).

3. Choose the Page (menu item) page type.

4. Type Home as the Page name and choose the Create a blank page option.

Save Save and create another
Edit

+ T B B ~ v P

Poge name: | Hore |

] My website L] O Use existing page template O Use parent page template O Create a blank page with layout @ Create a blank page

The new page will use new ad-hoc page template with an empty layout.

5. Click Save to create the page.

Designing the Home page

1. Switch to the Design tab.



2. Click the menu icon (== ) in the green page template header and select Edit layout in the menu.
3. Replace the default code with the following:

<tabl e styl e="wi dt h: 100% hei ght : 500px; border: Opx">
<tr valign="top">
<l-- left colum -->
<td styl e="w dt h: 280px" cl ass="HonePagelLeft Col uim" >
</td>
<l-- center colum -->
<td styl e="paddi ng: 3px 5px Opx 5px;w dt h: 450px; ">
<cms: CVs\WebPar t Zone Zonel D="zoneCenter" runat="server" />
</td>
<l-- right colum -->
<td styl e="paddi ng: 3px Opx Opx 5px;w dt h: 270px" >
<cns: CMSWebPart Zone Zonel D="zoneRi ght" runat="server" />
</td>
</[tr>
</ tabl e>

4. Click Save & Close.

. Add the Editable text web part into the zoneCenter web part zone.

. Configure (double-click) the web part and set the following properties:
® Editable region title: Main text
® Editable region height: 450

[eé)]

7. Add another Editable text web part into the zoneRight web part zone. Set its properties:
® Editable region title: Contact text
® Editable region height: 100

8. Open the Page tab. The page now contains two editable regions. Enter the following text:
® Main text: Welcome to the website.
® Contact text: Call 800 111 2222

9. Click Save.

To view the public appearance of your website's new Home page, switch to Preview mode.

Our Business, Inc.

‘Welcome to the website. Call200 111 2222

Choosing the website's home page

When a visitor arrives at the root URL of the website (i.e. its domain name, for example http://www.example.com), the system needs to know
which page to display as the home page.



To set the path of the website's default home page:

1. Open the Settings application.
2. Select the Content category in the settings tree.
3. Select My website in the Site drop-down.
4. Clear the Inherit from global settings check box next to the Default alias path setting.
5. Type in /[Home, which is the alias path of your new home page.
6. Click Save.
Site: Export these settings
[ My website ']
Multilingual
© Settings
© Content Default content culture: Inherit from global settings
URLs and SEO
© Security & Membership Eggshidlndedistates ML
© System Combine with default ~| Inherit from global settings
© On-line marketing culture:
© E-commerce o
© Community Combine files with default ~| Inherit from global settings
© Social media culture:
@ Social marketing v @
© Intranet & Collaboration
@ Versioning & Synchronization Web site content
© Integration
Default alias path: Inherit from global settings
/Home Select
Metadata

When visitors access the website without specifying the URL of a particular page, the system automatically displays the Home page.

Creating a container for the Home page text

Now we will create gray and blue web part containers for our home page text. You can reuse containers for any other web parts later. If you
do not wish to use web part containers, you can alternatively insert the surrounding code directly into the HTML layout of your page template.

Creating the web part containers

1. Open the Web part containers application.
2. Click New container.
3. Enter the following values:
® Display name: My website gray box
® HTML code:

<table style="width: 100% " cell spaci ng="0" cell paddi ng="0" border="0"
cl ass="Cont ai ner Wt hCor ners" >
<tr class="Contai ner Wt hCor ner sRow" >
<td cl ass="Cont ai ner Wt hCor ner sTopLeft">&nbsp; </ td>
<td cl ass="Cont ai ner Wt hCor ner sTop" >&nbsp; </t d>
<td cl ass="Cont ai ner Wt hCor ner sTopRi ght " >&nbsp; </t d>
</tr>
<tr>
<td cl ass="Cont ai ner Wt hCor nersLeft">&nbsp; </t d>
<td cl ass="Cont ai ner Wt hCor nersContent” valign="top">

</td>
<td cl ass="Cont ai ner Wt hCor ner sRi ght">&nbsp; </t d>
</tr>
<tr class="Contai ner Wt hCor ner sRow" >
<td cl ass="Cont ai ner Wt hCor ner sBot t onLeft">&nbsp; </t d>
<td cl ass="Cont ai ner Wt hCor ner sBot t ont' ></ t d>
<td cl ass="Cont ai ner Wt hCor ner sBot t onRi ght " >&nbsp; </t d>
</tr>
</tabl e>



The "™ character in the code above determines the position of the web part's HTML code within the container.

4. Click Save.

5. Switch to the Sites tab and assign the container to My website.

6. Return to the main container list and create another container with the following values:
* Display name: My website blue box
® HTML code:

<tabl e cel | paddi ng="0" cel | spaci ng="0" style="w dth: 100% "
cl ass="Bl ue">
<tr>
<td class="BoxTitle">{%ontai nerTitle% &bsp; </td>
</tr>
<tr>
<td cl ass="BoxArea">

</td>
</[tr>
</t abl e>

7. Click Save and assign the container to My website on the Sites tab.

Assigning the containers to web parts

Now that the containers are prepared, you can assign them to specific instances of web parts.

. Open the Pages application.
. Select the Home page in the content tree and open the Design tab.
. Configure (double-click) the editabletext web part in the zoneCenter zone.
. Scroll down to the Web part container property and select My website gray box.
. Click Save & Close.
. Configure (double-click) the editabletextl web part in the zoneRight zone
. Set the following properties in the Web part container section:
® Web part container: My website blue box
® Container title: Contact Us

~NOoO O~ WNBRE

8. Click Save & Close.

If you now view the Home page in Preview mode, you can see the gray box around the welcome text and the blue box around the contact us
text.

Our Business, Inc.

Welcome to the website.

Call 800 111 2222

Developing the News page

Now we will create the News section of the tutorial website.

1. In the Pages application, select the root page (My website).



2. Click New ().
3. Choose the Page (menu item) page type.
4. Type News as the Page name and select the News -> News list page template.

Page name: = MNews

® Use existing page template Use parent page template Create a blank page with layout Create a blank page

@ Al page templates

Avrticles
Blogs
Events
I I ) -
FAQs e —_— — o=_
I I
Forums —_— _— | o=
— — — p—
Home pages
MNews list News simple list MNews with summary News with summary

Images and teasers
Job openings

Krowledge base

General

Master templates

Membership and security

News

Newsletter

5. Click Save.

The News page uses a predefined template, so it is ready without any further modifications.

Creating news articles

To add news articles to the website:

. In the Pages application, select the /News page.

. Click New ().
. Choose the News page type.
. Fill in the news page fields with the following values:
®* News Title: News 1
Release Date: click Today
News Summary: News 1 summary.
News Text: News 1 text.
Publish from/Publish to: leave the fields blank

A WN B

5. Click Save and create another and enter the following values:
®* News Title: News 2

Release Date: click Today

News Summary: News 2 summary.

News Text: News 2 text.

Publish from/Publish to: leave the fields blank

6. Click Save.

If you select the /News page and switch to Preview mode, you can see a list of all news pages placed under the News section.



Our Business, Inc.

Home News

News

Hews 1
MNews 1 summary.
Hews 2

MNews 2 summary.

This is an example of how content is structured in Kentico. If you select a specific news item, the page displays the detail view.

The breadcrumbs at the top of the page show the current path on the website: News > News 1. The position is also reflected in the default
page URLs:

® The URL of the News page is ~/news.aspx
® The URL of the News 1 page is ~/news/news-1.aspx

This makes the website accessible to both people and search engines.

How does the News list work?
You may be wondering how Kentico generates the news list. The news page is a good example of using web parts to display structured page
data on the website.

Select the News page, switch to Edit mode and open the Design tab. The page contains several web parts, including the NewsRepeater.
This web part is based on the Repeater web part, which loads content from the database. Configure (double-click) the web part to view how
the web part's properties are set.

The most important properties are the following:

Property Value Description
Path Determines the path of the pages in the content tree from which the web part loads and displays
data.

If you leave the value empty, the web part displays all pages under the current path (for pages) or
displays the details of the selected page (for News pages).

See Path expressions

Page types cms.news This property determines what types of pages the web part displays (news, products, blogs etc.).



Transformation cms.news.preview Assigns the transformation that the web part uses to display the list of news items. A transformation

is a piece of code which converts raw database data of a page into user-friendly HTML output.

Selected item  cms.news.default =~ When a user selects a specific news item on the website, the repeater displays the details
transformation according to the specified transformation.

The following steps show how the page handles visitors:

1.
2.

3.

4.

A visitor arrives on the /News page.

The Repeater web part placed on the page template checks if a news page is currently selected (based on the value of the Page
types property).

The web part finds out that the current page is a Page (menu item), so it looks for all underlying news pages and displays them as a
list using the cms.news.preview transformation.

When the visitor selects a particular news item, such as /News/News 1, the repeater web part uses the cms.news.default transfor
mation instead to display the details.

Path expressions

Listing web parts and controls have the Path property that specifies which content the component loads and displays. The following
expressions are examples that you can use to select pages:

Path expression  Meaning

1%

All pages on the website.

/news/% All pages under /News.

Inews/news1 The Newsl1 page.

1% All items under the current page.

Jlogo The Logo page under the current page.

Jimages/% All pages under the Images page, which is a child of the current page.
../contacts/% All pages under the Contacts page on the same content level as the current page.
1{0}/% All pages under the page located on the first level of the current path.

Example:

If the currently selected page is:
/news/news1
the system evaluates the expression as:

/Inews/%

Developing the Services page

Now we will add a website section displaying information about services. The page template used for this section will contain a tree menu on
the left and two editable regions.

ONOUAWN B

. In the Pages application, select the root page (My website).

. Click New ( ).
. Choose the Page (menu item) page type.

Type Services as the Page name and choose the Create a blank page with layout option.

. Select the Two columns - 20/80 layout with the Copy this layout to my page template box checked.

. Click Save to create the page.

. Open the Design tab and add the Tree menu web part into the zoneB zone (left zone on the middle row).
. Set the following properties for the Tree menu web part:

Property Value Description
Content -> {0}/ % Configures the tree menu to display pages starting from the second
Path level of the currently selected path.

Design -> ltem  ~/app_themes/mysite/images/bullet.gif ~Sets the path of the image that the menu displays next to items.

image URL . . .
The ~ character represents the root of the website. This relative path

ensures that the web part displays the images correctly even if the
website's virtual directory name changes.



Design -> ~lapp_themes/mysite/images/bullet.gif Specifies the image displayed next to items in the tree menu that
Open item belong on the path of the currently selected page.

image URL

9. Click Save & Close.
10. Add the Editable text web part into the zoneC zone (right zone on the middle row) and set the following properties:
* Editable region title: Header
Editable region type: Text box
Editable region width: 600
Content before: <h1>
Content after: </h1>

11. Add another Editable text web part below the first one and set the following properties:
® Editable region title: Main text
® Editable region type: HTML Editor
® Editable region height: 300

The Design tab of the Services page should now look like this:

Page Design Form Properties 4 Analytics «

Our Business, Inc.

Home News Services

= cmstreemenu = editabletext

editabletextl

This is a sample Kentico website

Entering text

1. Switch to the Page tab of the Services page.
2. Type some text into the editable regions.
3. Click Save.

Page Design Form Properties 4 Analytics 4

Wsorce X 0 B @ @B « + Qb3 7 B I US x x [ :=

- W @ [ Stiles ~  Format - Font - size - A- @ {8 32 4

Qur Business, Inc.

Header
Qur Senices

\Our services are the best]

Home News Services

Creating are-usable page template

Save the current state of the page as a re-usable page template.



1. With the Services page selected, go to the Properties -> Template tab.
2. Click Save as new template.
3. Fillin the following values for the new template:

® Template display name: Services template

® Template category: General

® Assign to the current page: yes (checked)

4. Click Save & Close.

You can now select the Services template directly when creating new pages.

Adding sub-pages

Now use the Services template to add separate pages containing information about individual services under the Services page.

1. In the Pages application, select the /Services page in the content tree.
2. Click New (+).
3. Choose the Page (menu item) page type.
4. Type in Service 1 as the Page name and choose the Use existing page template option.
5. Select the General category and the Services template page template.
6. Click Save.
7. Type the following text into the editable regions on the Page tab:
® Header: Web hosting
® Main text: We provide professional web hosting.
8. Click Save.

To see how the Service 1 page appears to website visitors, switch to Preview mode.

Edit m Listing View Validate 4

+ @ BB AV DO

@ il My website []

B Home (]

o B News (]

@ B Services (]
B service 1 °

P Service 1

Web hosting

We provide professional web hosting

The Services section demonstrates how to create a new page template from scratch and re-use it for any number of pages. The system
stores the text of editable regions separately for every page, so you can enter unique content on each page.

Developing the Products section

Now we will add a products section displaying a list of computers and their technical specifications. You will learn how to:

1. Create a new page type representing computer products
2. Write transformations
3. Create a page displaying a list of computer products

Defining a new page type
Each page in Kentico is of a certain type, such as page, news, product, article, etc. Every page type has its own data fields. The page type
describing computer products will have fields storing the computer name, processor type, RAM size, disk size and product image.

1. Open the Page types application.
2. Click New page type. This starts the New page type wizard.
3. Enter the following values in Step 1:
® Page type display name: Computer (the system displays this name to users in the administration interface)
®* Namespace: custom (namespace to distinguish your page types from the default system types that use the cms
namespace)
® Name: computer (the identifier of the page type)



Steplof7 @ General

Please enter page type display name (for users) and code name (it will be used in your code when necessary).

Page type display name: Computer

Page type code name:
Namespace: custom

Name: computer

. Click Next.

. In Step 2, specify the name of the database table where the system stores the data of computer pages. You also need to enter the
name of the table's primary key field. Leave the default values.

. Click Next. The system creates a new database table for computer pages.

. In Step 3, you need to define the fields of the page type (columns of the table). Click New field to create the following fields. For
each field, enter the values, click Save and repeat the procedure until you have defined all the listed fields.

Field name: ComputerName
Data type: Text

Size: 200

Required: yes (checked)

Field caption: Computer name
Form control: Text box

Field name: ComputerProcessorType

Data type: Text

Size: 200

Field caption: Processor type

Form control: Drop-down list

Editing control settings -> Data source: select List of options and enter the following items into the text area, one per
line:

At hl on; At hl on
Pent i um XEON; Pent i um XEON
Pentium Core 2 Duo; Pentium Core 2 Duo

Field name: ComputerRamSize
Data type: Integer number
Field caption: RAM (MB)

Form control: Text box

Field name: ComputerHddSize
Data type: Integer number
Field caption: HDD (GB)
Form control: Text box

Field name: Computerimage
Data type: File

Field caption: Image

Form control: Upload file



10.
11.

12.

13.

14.
15.

Step 3of 7 | Fields

Please define custom fields of the page type and their appearance in the editing form. You can define fields, such as product number, product
weight. press release text. etc.

New field - B A v Field type: File

Required:

ComputerName

ComputerProcessorType Translate field:
ComputerRamSize
ComputerHddSize

New field

GUID:

v| Display field in the editing form

Field appearance
Field caption: b | Image

Field description: b

Explanation text: p

Form control: Upload file v

. Click Next.
. In Step 4, choose the ComputerName field as the Page name source.

This means that when a user creates a new computer page, the system automatically fills in the page name based on the
ComputerName value. The page name appears in site navigation and in the content tree of the Pages application.

Click Next.

In Step 5, select the page types that will be supported as parents for computer pages in the content tree. Click Add page types,
select the Page (menu item) page type and click Select. This means that users are only allowed to place computer pages under
pages, not under articles, news items or other page types.

Click Next.

In Step 6, assign the page type to all websites where you wish to use it. Click Add sites, choose My website in the selection dialog
and click Select.

Click Next.

Click Finish to complete the creation of the new page type.

The wizard automatically creates the database table and several default transformations.

How does the system store page content?

The system stores page content and all related data in three database tables:

® CMS_Tree (content tree structure)
® CMS_Document (general page properties, metadata and editable region content)
* A dedicated page type table - in this case CUSTOM_Computer (stores the values of the page type's specific fields)

Writing transformations

Now that you have created the new page type, you need to prepare the transformations that page components will use to display computer
products on the website.

1.

2.
3.

Open the Page types application.

Edit ( s ) the Computer page type.
Switch to the Transformations tab.



L] New hierarchical transformation
General _

= Actions Transformation name .. Transformation type
Fields & F - Atomitem ASCX
Layout ," i === Default ASCH

. * B = Preview ASCX

Transformations s

# W - RSSltem ASCH
Queries

The New page type wizard has created several default transformations, which you can use as a base for your own
transformations.

4. Edit ( s ) the Default transformation, clear the original code and replace it with the following:



<h1l>
<%t Eval (" Conput er Nane") %
</ hl>
<t abl e>
<tr>
<t d>
Processor:
</td>
<t d>
<%t Eval (" Conput er Processor Type") %
</td>
</[tr>
<tr>
<t d>
RAM ( MB) :
</td>
<t d>
<%t Eval (" Conput er RantSi ze") %
</td>
</[tr>
<tr>
<t d>
HDD ( GB):
</td>
<t d>
<%t Eval (" Conput er HddSi ze") %
</td>
</[tr>
<tr>
<t d>
| mage:
</td>
<t d>
<0 Getl nmage(" Conputerlmage") %
</td>
</[tr>
</tabl e>

ASCX transformation code is similar to standard ItemTemplate elements that you may already be familiar with from from
using ASP.NET Repeater or DatalList controls. The transformation code combines HTML with ASP.NET commands and
data binding expressions (Eval). You can also use built-in methods that simplify various tasks, such as Getimage. For
more information about the available transformation methods, click the Available transformation methods link above the
code editor.

You will use the Default transformation for displaying the details of individual computer products.

5. Click Save.
6. Return to the transformation list and edit the Preview transformation. Clear the default code and add the following code instead:

<div style="text-align:center; paddi ng: 8px; margi n: 4px; border: 1px solid
#CCCCCC' >
<h2>
<a href="<%t GetDocunentUrl () %"><%t Eval (" Conputer Nanme") %</a>
</ h2>
<%t Cetl mage(" Computerl mage", 120) %
</ div>

7. Click Save.



Note the code used to create the link to specific pages. It consists of a standard HTML link tag and inserts the appropriate URL and link text
dynamically:

<a href="<%t GetDocunentUrl () %"><%t Eval (" ConputerNanme") %</a>

You can generate an image tag containing the file uploaded into the given page's Computerimage field using the Getimage method. The
sample code calls the method with a parameter that ensures automatic serverside resizing of the image's longest side to 120 pixels:

<%t Cetlmage(" Conputerlmage", 120) %

You will use the Preview transformation for displaying the list of computer pages on the main products page.

Entering field names in transformations

When writing ASCX transformations, you often need to specify the names of data fields as parameters of the Eval data binding
expression or other methods, such as ComputerName and Computerlmage in the examples above.

You can press CTRL + SPACE to access a list of available page fields and related objects instead of typing them manually.

Creating the Products page

This page describes how to add the product list page and publish computer specifications on the website.

Creating the product list page

. Open the Pages application.
. Select the root page (My website).

. Click New ().

. Choose the Page (menu item) page type.

. Type Products as the Page name and choose the Create a blank page option.

Click Save to create the page.

. Switch to the Design tab and add the Breadcrumbs web part into zoneA. Leave the default properties for the web part and click Sa
ve & Close.

8. Add the Datalist web part below the breadcrumbs. Set the following properties for the web part:

Nouuhsw MR

Property Value Description

Page types custom.computer Configures the datalist to display only pages of the custom.computer type (created
in the Defining a new page type topic).

ORDER BY ComputerName ASC Sets the SQL ORDER BY clause that the web part uses when loading data. As a
expression result, the datalist displays items in ascending alphabetical order based on the
values of the ComputerName field.

Transformation custom.computer.preview Assigns the transformation that the datalist uses to display the list of computer
products.

Selected item  custom.computer.default ~ When a user selects a specific computer page on the website, the web part displays
transformation the details according to the specified transformation.

9. Click Save & Close.

The page is now ready to display underlying computer pages.

Adding computer pages

Now add pages representing individual computer products:

1. In the Pages application, select the Products page in the content tree.

2. Click New ( + ) and choose the Computer page type.
® Computer name: Home PC Dallas
Processor type: Athlon
RAM (MB): 2048
HDD (GB): 160
Image: upload an image (you can find images in the Sample web template - SampleWebTemplate\Computer_Images)
Publish from/Publish to: leave the values blank


https://docs.kentico.com/download/attachments/58339547/SampleWebTemplate.zip?version=1&modificationDate=1394196859133&api=v2

3. Click Save and create another and enter the following values:
® Computer name: Office PC Houston
Processor type: Pentium Core 2 Duo
RAM (MB): 4096
HDD (GB): 200
Image: upload an image (you can find images in the Sample web template - SampleWebTemplate\Computer_lmages)
Publish from/Publish to: leave the values blank

4. Click Save.

You can edit the field values of the computer pages at any time by switching to the Form tab in the Pages application.

Page Design Form Properties 4 Analytics 4
© il My website (]
li Home o Computer name: | Office PC Houston I
© i News (]
o K Products [] Processor type: | Pentium Core 2 Duo v
[ Office PC Houston ]
[ Home PC Dallas ] RAM (MB): | AR I
ok s o
B services HDD (GB): | 200 |
Image: # W Computer?jpg
Choose File | No file chosen
Publish from: | I B No
I Publish to: | | B No

If you view the /Products page in Preview mode, you can see a list of the two computer products (formatted according to the custom.compu
ter.preview transformation).

Qur Business, Inc.

Home News Products Services

Products

Home PC Dallas Office PC Houston

When you click the title of a specific computer, the page displays the detail view (using the custom.computer.default transformation).


https://docs.kentico.com/download/attachments/58339547/SampleWebTemplate.zip?version=1&modificationDate=1394196859133&api=v2

Qur Business, Inc.

Home News Products Services

Products = Home PC Dallas

Home PC Dallas

Processor: Athlan
RAM (MB): 20428
HOD (GB). 168

Image:

Developing the Search page

Kentico allows users to perform index-based searches through all page content, as well as other types of data. The following instructions
describe how to add a basic search page to your website.

Configuring search fields for the Computer page type

First, set up the search options for the Computer page type that you created for the Products section.

. Open the Page types application.

. Edit ( s ) the Computer page type.

. Switch to the Search fields tab.

. Select the Search is enabled check box.

. Set the Image field to Computerimage.
. Click Save.

O WN B

Product pages are now searchable.



Search is enabled: v
Title field: DocumentMame w
Content field: DocumentContent S
Image field: Computerlmage W
Date field: DocumentCreatedWhen W

Set automatically

Field name Content Searchable Tokenized Custom search name
ComputerID v

ComputerMame o v

ComputerProcessorType |+ 9

ComputerRamSize v

ComputerHddSize v

Computerlmage

Creating a smart search index

Before you can use the search, you need to add a smart search index covering the website's pages.

1. Open the Smart search application.
2. Click New index.
3. Fillin the following details for the search index:
® Display name: My website - Pages
® Index type: Pages
® Analyzer type: Standard
® Stop words: (default)

. Click Save. The index's editing interface opens.

. Open the Indexed content tab and click Add allowed content.

Type /% into the Path field and click Save. This ensures that the index includes all pages on the website.
. Switch to the Sites tab and assign the index to My website.

. Switch to the Cultures tab and choose the default culture of your site (typically English - United States).

. Open the General tab and click Rebuild.

© o ~NOUN

Once the system rebuilds the index, you can start using it on the website. The Index info section displays the current status of the index and
other relevant information.
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General
General

Sites

Display name* | My website - Pages |

Cultures

Code name:™ | MyWebsite-Pages | e

Indexed content

; Index type* Pages
Search preview

Analyzer type: | Simple v

Batch size: | - |

Adding the search page

. Open the Pages application.
. Select the root of the content tree (My website).

. Click New ().

. Choose the Page (menu item) page type.

. Type Search as the Page name and choose the Use existing page template option. Select the General category and the Search t
emplate.

. Click Save to create the page.

. Click and drag the Search page to the end of the page list.

. Switch to the Design tab and Configure (double-click) the SearchDialogWithResults web part.

. Click Select next to the Indexes property and choose the My website - Pages search index created in the previous section.

10. Click Save & Close.

asrw NP
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To try out the search functionality, view the /Search page in Preview mode. Type PC into the Search for box and click Search.

Our Business, Inc.

Home News Products 5ervices Search

Search results

Search for:

pc |

Search mode:

| Ay word v

Home PC Dallas

s /Kentico_2.0_0305/Products/Home-PC-Dallas.aspx 3712014 10:05:04 AM

Office PC Houston

s /Kentico_8.0_0305/Products/Office-PC-Houston.aspx 3/7/2014 10:07:04 AM

When you click a search result, the system redirects you to the corresponding page.



Modifying the format of the search results

If you prefer a different design of the search results, you can modify the format by editing the SmartSearchResults (or SmartSear
chResultsWithImages) transformation in Page types -> Root -> Transformations.

Adding a secured section for partners

Kentico provides a way to create secured site sections that can only be viewed by users who have a valid user name and password. This
page describes how to create a logon web page for the purposes of user authentication and registration, as well as a secured page
accessible only by logged in users.

Adding the secured partners page

Start by adding a new secured page that requires authentication:

1. Open the Pages application and select the root of the content tree (My website).
2. Click New (F).
3. Choose the Page (menu item) page type.
4. Type Partners as the Page name and choose the Use existing page template option. Select the Templates with editable
regions category and the Simple text page template.
5. Click Save to create the page.
6. On the Page tab, type the following text into the editable region: This is a secured page for partners.
7. Click Save.
8. Open the Properties -> Security tab of the Partners page.
9. Select Yes for the Requires authentication property in the Access section
10. Click Save.

This ensures that only authenticated (logged in) users can access the page.

Creating the logon page

Now build a page where users can sign in to the website and anonymous visitors can register as new users. Use a predefined page
template, which you can further customize as needed.

. In the Pages application, select the root of the content tree (My website).

. Click New ( F).

. Choose the Page (menu item) page type.

Type Logon as the Page name and choose the Use existing page template option. Select the Membership and security categor
y and the Log-on page with registration form page template.

. Click Save to create the page.

. Drag the Logon page to the end of the content tree.

. Open the Properties -> Navigation tab.

. Clear the Show in navigation and Show in sitemap check boxes.

. Click Save.
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Because of the page's navigation settings, the Logon page does not show up in the website's menu. You can use this configuration for pages
that have a special purpose on the website, but are not part of the regular content.

Setting the website's logon page

When an anonymous visitor attempts to access a secured page that requires authentication (such as the Partners page on your sample
website), the system redirects them to a logon page. By default, websites use the system page that appears when signing into the Kentico
administration interface. However, you can configure each website to use its own custom logon page.

. Open the Settings application.

. Select the Security & Membership category in the settings tree.

. Select My website in the Site drop-down menu.

. Clear the Inherit from global settings check box next to the Website logon page URL setting and type in ~/Logon.aspx. This is
the relative URL of the logon page that you added to the website.

5. Click Save.

A WNPE

The website's logon page is now ready.

Adding a sign out button to the website

The website now allows users to log in, so you should also provide a way to log out. You can do this by adding the appropriate web parts to
the website's master page.

1. Open the Pages application.
2. Select the root of the content tree (My website).



3. Switch to the Design tab.
4. Add the following web parts to the zoneMain web part zone and set their properties:

Current user
® Content before: <div style="float:right">

Sign out button
® Content after: </div>

The <div> tag encloses the Current user and Sign out button web parts and floats them to the right side of the page.

5. Set the following order for the web parts in zoneMain (you can drag web parts using your mouse):
1. Current user
2. Sign out button
3. Page placeholder

The Sign out button and the web part showing the current user's name are now visible for signed in users on all pages on the website.

Preview ‘ Listing Page Design Form Master page

]

+ 7§ B A~ v O

@ Im My website o
B Home ° Our Business, Inc.
o B News S
B Partners [
© B Products o
© B Services o = cmsmenu
B Scarch o - :
. = zoneMain
E Logon [
= currentuser
= SignOutButton
= [ pageplaceholder

Result - Logging in to the website

Now that you have added the logon page, secured section and sign out button to the website, you can test the new functionality from the
perspective of a live site user.

1. Open the user menu on the right of the Kentico administration interface header, and select Sign Out.

2. Click Partners in the main menu. The page is restricted, so the website redirects you to the logon page.

3. Log in as the administrator again or try registering a new account. After you sign in successfully, the site automatically redirects you
back to the Partners page.

Our Business, Inc.

Home News Partners Products Services Search

This is & secured page for partners.

Current user: Global i (administrater) | Sign Out

Here you can see the content of the secured page, as well as the name of the current user and the Sign Out button.

Kentico also allows you to display content according to the read permissions of users. For example, you can grant the Read
permission for a Gold partners section to members of the Gold partners role, so that only gold partners are able to see the
corresponding menu item and page content.

See Configuring permissions in the main documentation for more information.



https://docs.kentico.com/display/K82/Configuring+permissions

Creating pages using ASPX templates

ASPX page templates in Kentico allow you to control every aspect of page processing. On an ASPX template, you can use standard
ASP.NET controls, as well as controls and web parts provided by Kentico. You can also modify the code of the pages freely. However, in
exchange for the customizability of pages, you lose the convenience of adding and configuring web parts and widgets directly from your
browser.

Most Kentico Certified Developers prefer using the Portal engine over developing ASPX templates.
To develop ASPX templates, you need:

® Microsoft Visual Studio or an equivalent IDE
® knowledge of ASP.NET and C# or VB
® asupported web browser

ASPX page templates

If you are familiar with ASP.NET development in Visual Studio, you can develop Kentico websites using ASPX page templates.

ASPX page templates are standard ASP.NET web forms. When you register ASPX templates in the system, users can create pages based
on the templates and fill in content. The system internally uses the aliasPath URL parameter, which identifies the Kentico page whose
content the template displays.

What is a page template?

Every web page is based on a page template. The page template can be specific for a single page (so called "ad hoc" page template) or
re-used for any number of pages. The following picture shows examples of pages that use the same page template.

Pages Created Using the Page Template

——
@ ompany

Empty Page Template

O IT Company

(@ Mompany

The pages have different content, but use the same header, menu content structure, and footer — they are based on the same page
template. Templates allow you to quickly create multiple pages with the same design.

What do ASPX page templates consist of?

The content of page templates is a combination of static HTML code and ASP.NET server controls (or user controls) that render dynamic
content. You can also use code behind (using either VB.NET or C#) to modify page behavior and add custom functionality.

The following figure illustrates how Kentico combines ASPX page templates with the content of individual pages to display the final result.


https://docs.kentico.com/display/K82/Server+and+hosting+requirements

Web form code ASPX page template with controls

<¥i Page Language="'C#">

<table>

<tr>

<tds>

<cms:CMSEditableRegion runat="server" ID="leftRegion" />

< ftd> -—
<td>

<cms:CMSEditableRegion runat="server" ID="topRightRegion" />
<cms:CMSEditableRegion runat="server" ID="bottomRightRegion"” />
</td>

<ftr>

<[table>

How does the system process ASPX page templates?

When a user requests a page, such as ~/Company.aspx, the system internally calls the page template assigned to the given page with the a
liasPath URL parameter. The parameter specifies what content (which page from the content tree) the page template displays to the user.



User requests page:
http://localhost/CorporateSite/Company.aspx

<&

The Kentico URL rewriting engine processes the request.
The system determines that the /Company page uses the SingleArticle.aspx template.

The path is rewritten to:
http:/flocalhost/CorporateSite/SingleArticle.aspx?aliasPath=/Company

) 4

The controls on the page template get the value of the aliasPath parameter from the URL and load
content for the /Company page. Any custom code on the template is also executed.

4

Optional: The output filter processes the page’s output code and fixes tags, URL format, and XHTML
incompatibilities.

4

The final page is displayed to visitors in the browser.

Kentico controls or web parts placed on the page template process the aliasPath parameter in the URL, and render the appropriate content
automatically.

On the front-end, Kentico generates URLs in format <domain>/Company.aspx, which are more user-friendly and better for search engine
optimization.

Creating a simple ASPX page template

This page describes how to create a new ASPX page template. We will create a new page with two columns that contain editable regions.

Creating the web form

1. Open your web project in Visual Studio (using the WebSite.sIn or WebApp.sin file).
2. Right-click the CMSTemplates/CorporateSite folder in the Solution Explorer and select Add -> Add New Item.



3. Create a new Web form named: TwoColumnTemplate.aspx
® Check Select master page.
4. Click Add. The Select a Master Page dialog opens.
. Choose the CMSTemplates/CorporateSite folder and select the default Root.master file.
6. Click OK.

(4]

Writing the ASPX code

1. Open the Source view of the new web form.
2. Add the following code inside the <asp:Content> element:

<t abl e>
<tr>
<td style="w dth: 50% >
<cns: CVSEdi t abl eRegi on I D="txtLeft" runat="server" D al ogHei ght="400"
Regi onType="H m Editor" RegionTitle="Left colum" />
</td>
<td style="w dth: 50% >
<cns: CVSEdi t abl eRegi on | D="t xt Text" runat="server" Di al ogHei ght ="400"
Regi onType="H m Editor" Regi onTitl e="Ri ght colum" />
</td>
</tr>
</tabl e>

® The <asp:Content> control allows you to use standard ASP.NET master pages. When the system renders the
page, it loads the content of the control into the assigned master page (as defined in the Root.master file).

* The CMSEditableRegion control defines an editable region that the page displays as an HTML editor in the
Kentico administration interface on the Page tab of the Pages application. On the live site, the control renders the
content entered into the editor.

This example uses a table layout. If you prefer a CSS layout, replace the surrounding HTML code with <DIV> elements.
You have full control over the content.

3. Edit the web form's code behind file (TwoColumnTemplate.aspx.cs).
4. Add a reference to the CMS.UIControls namespace:

using CVS. U Controls;

5. Modify the class declaration so that the web form inherits from TemplatePage:

public partial class CMSTenpl ates_Cor porat eSite_TwoCol umTenpl ate :
Tenpl at ePage

6. Save the web form's files.
Inheriting from the TemplatePage class allows you to use the web form as a page template in Kentico.

Keep in mind that the name of the class must be identical to the value of the Inherits attribute of the <% @ Page %> directive on the ASPX
page. This is case sensitive.

Registering the web form as a page template

Now you need to register the web form as a page template in Kentico, so that it can be selected when creating pages.

. Log in to the administration interface and open the Page templates application.
. Select the Corporate Site/Examples category.

. Click New template.

. Type Two column template into the Template display name field.

. Click Save.

. Set the following values on the General tab:

o U WNE



®* Template type: ASPX page
® File name: ~/CMSTemplates/CorporateSite/TwoColumnTemplate.aspx

New template = @ D

@ All page templates

© Ad-hoc

Articles

Blank

Blank pages for widgets
Blogs

Corpaorate Site

@ Examples
A/B test example page template
Carporate Site - Development r
Carporate Site - Development r
Carporate Site - Development r
Carporate Site - Mobile develop
Carporate Site - Mobile develop
Carporate Site - Mobile develop
Carporate Site - Mobile develop
Corporate Site - Mobile develop
Corporate Site - Mobile develop
Corporate Site - Responsive Ma
Corporate Site - Web Part (sam
Two column template

@ Mobile

@ MVC

10.

General Design

Save

Template display name:®

Template code name:*

Category:

Template description:

Thumbnail:

Template type:

File name:

Layout Sites

Scopes Web parts Header

Two column template

TwoColumnTemplate

Examples

Image

Upload file

ASPX page

~/CMSTemplates/CorporateSite/TwoColumnTem

Documents Versions
A
v
v
Select Clear

Click Save.
Switch to the Sites tab.
Click Add sites.

© 0N
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Page name: | About Us

®) Use existing page template

® Al page templates
Articles
Blank pages for widgets
© Corporate Site

Examples
MVC
Moabile

Blogs

Events

FAQs

Forums

Home pages

Images

Job openings

Knowledge base

General

Master templates

Membership and security

News

Mewsletter

Offices

Press releases

Products

. Open the Pages application.
Select Corporate Site (the root of the content tree).

click New ( F ) above the tree.

Choose the Page (menu item) page type.
. Type About Us as the Page name and choose the Use existing page template option.
Select the Corporate Site/Examples category and the Two column template page template.

Creating a page based on the template

Content editors can now use the page template to create pages.

Choose the sites where you wish to use the page template (Corporate site) and click Select.

Save Save and create another

Use parent page template

Ya

A/B test example Corporate Site -

Create a blank page with layout

Create a blank page

Corporate Site -

Corporate Site -

Corporate Site -

page template De F

model (ASPX)

Corporate Site -
Mohile
development -
CMSConditionallLay

Corporate Site -
Mohile
development -

Corporate Site -
Responsive Master
page

Corporate Site -

CMSDevicelayout

Web Part (sample)

Develog Devel
model (Mixed)

Corporate Site -
Mohile

development -
CMSDevicelayout

|
Two column
template

Engine)
il
il

Mohile

model (Portal

Corporate Site -

development -
Custom layout

Mobile
development -
CMSConditionallay

—

Corporate Site -
Mohile
development -
Mapped layout

7. Click Save to create the new page.

On the Page tab, you can see the page and its editable regions.




Page Form Properties 4 Analytics 4

Spell check Apply workflow

[ Source BB @ % <+ QI B I UGS x, x ==

B mE

Styles - Faormat - Font - Size -

{11
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i
»
0
=

Sign in to Administration. The default account is administrator with blank password.

O IT Company

Home Products News Community Senvices Company Media
>
Leftcolumn Rightcolumn |

This is text in an editable region_..

You can now type in text into the regions and click Save to store the content of the page.

Moving pages

If you want to move the About Us page to a different position, you can drag the page to the desired location in the content tree, or
click the Move up ( ~ ) and Move down (V ) actions.

Using master pages

You can use standard ASP.NET master pages together with ASPX page templates. This is a powerful concept that allows you to share
content across all pages without having to add it separately to every page template. For example, you can create master pages containing
header and footer sections with a logo, navigation menu, search box etc.

* Define master pages in files with the .master extension.
® You can assign one master page to every ASPX page.
® Master pages must always contain one or more ContentPlaceHolder controls:

<asp: Cont ent Pl aceHol der | D="pl cMai n" runat="server"></asp: Cont ent Pl aceHol der >

The ContentPlaceHolder control specifies where child pages display their content inside the master page.

Tip: We recommend storing master pages in the CMSTemplates folder together with your ASPX page template files. This allows
the system to export master pages along with your website when you deploy it to another instance of Kentico.

Creating master pages for ASPX templates

The following code sample shows the markup of a basic master page.

Important

® |f you installed the Kentico project as a web application, you need to rename the CodeFile attribute on the first line to Cod


http://msdn.microsoft.com/en-us/library/wtxbf3hh%28v=vs.100%29.aspx

ebehind for the code example to be functional.
® The CodeFile/Codebehind attribute's value must match the name of the master page's code behind file.
® Set the value of the Inherits attribute according to the location and name of the master page file.

<%@ Mast er Language="C#" Aut oEvent Wreup="true" CodeFil e="Custom nmaster.cs"
I nherits="CMSTenpl at es_Cor por at eSi t e_Cust om' %

<%DocType%

<htm xm ns="http://ww.w3. org/ 1999/ xhtm " <%Xm Nanespace%>
<head i d="Headl" runat="server">

<title id="Titlel" runat="server">M site</title>

<asp:literal runat="server" id="ItlTags" enabl evi ewstate="fal se" />
</ head>

<body cl ass="<%Bodyd ass%" <% BodyPar anet er s¥%>
<formid="fornl" runat="server">
<asp: Pl aceHol der runat ="server" |D="pl cManagers">
<aj axTool ki t: Tool ki t Scri pt Manager | D="manScri pt" runat="server"
Enabl eVi ewSt at e="f al se" Scri pt Mode="Rel ease" />
<cms: CVSPor t al Manager | D="CMsPort al Manager 1" runat ="server"
Enabl eVi ewSt at e="f al se" />
</ asp: Pl aceHol der >

<cms: CMsMenu | D="cnmsnenul" runat="server" Cursor="Pointer"
H ghlight Allltensl nPat h="true" Layout="Horizontal" Paddi ng="0" Spaci ng="1" />

<asp: Cont ent Pl aceHol der | D="pl cMai n" runat="server">
</ asp: Cont ent Pl aceHol der >
</forme
</ body>
</htnml >

All ASPX page templates require the following manager controls, so it is a good practice to add them onto your website's master page:

Control name Description

ajaxToolkit: ToolkitScriptManager ~ Allows pages to use AJAX components. If required, the CMSPortalManager automatically loads the To

olkitScriptManager, but adding the control directly reduces overhead.

CMSPortalManager Ensures the transferring of content between the database and editable regions. Also provides the

management functionality needed for portal engine zones.

The CMSPortalManager must be placed inside a standard PlaceHolder control.

The CMSMenu control is one of the options that you can use to generate a drop-down menu for website navigation.

Writing the master page code behind

You need to modify the code behind file of your master pages according to the following steps:

1. Add a reference to the CMS.UIControls namespace:

usi ng CVS. Ul Controls;

2. Change the class definition to match the following (the name of the class may be different):


http://msdn.microsoft.com/en-us/library/cc295504.aspx

public partial class CMSTenpl ates_Cor porateSite_Custom : Tenpl at eMast er Page

Master pages of ASPX templates must always inherit from the TemplateMasterPage class.

3. Add the following code into the master page's code behind class:

Adjust the value of the PageManager property according to the ID of the CMSPortalManager control placed on the master
page.

protected override void CreateChildControl s()

{
base. Creat eChi |l dControl s();
PageManager = CMSPort al Manager 1;
}
protected override void OnPreRender (Event Args e)
{
base. OnPr eRender (e) ;
this.Itl Tags. Text = this. Header Tags;
}

This code ensures that ASPX templates using the given master page support all required functionality.

Adding portal engine functionality to ASPX templates

When developing or maintaining a website using ASPX page templates, one of the drawbacks is that you need to manually modify the code
of pages whenever you wish to change the design. You can add flexibility to ASPX templates by defining areas that are editable directly
through the browser in the Pages application, just like when using the Portal engine development model. To learn more about portal engine
features, please read the version of this tutorial dedicated to the portal engine.

The following example demonstrates how to create an ASPX page template with zones that users can design via the portal engine:

Writing the ASPX code

1. Open your web project in Visual Studio (using the WebSite.sIn or WebApp.sin file).
. Rightclick the CMSTemplates\CorporateSite folder in the Solution Explorer and select Add -> Add New Item.
3. Create a new Web form named: TwoZones.aspx

® Check the Select master page box.

N

4. Click Add. The Select a Master Page dialog opens.
. Choose the Root.master page from the CMSTemplates/CorporateSite folder and click OK.
6. Open the Source view of the new ASPX page and place the following inside the <asp:Content> element:

[&)]



<cns: CVsPagePl acehol der | D="pl cZones" runat="server">
<Layout Tenpl at e>
<tabl e style="w dt h: 100% >
<tr>
<td style="w dth: 50% >
<cns: CVBWebPart Zone | D="zonelLeft" runat="server" />
</td>
<td style="w dth: 50% >
<cns: CVMsWebPart Zone | D="zoneRi ght" runat ="server" />
</td>
</[tr>
</t abl e>
</ Layout Tenpl at e>
</ cns: CMSPagePl acehol der >

The CMSPagePlaceholder control creates an area on the page that behaves in a way similar to a portal engine page
template.

The <LayoutTemplate> element defines the layout of the area. This example uses a basic two column table structure, but
setting a CSSbased layout applied through HTML elements (for example <div>, <span>) is also a valid option.

The table contains two CMSWebPartZone controls, which represent fully functional portal engine zones. Users can
manage these zones when editing pages based on the page template on the Design tab of the Pages application.When
web part or widget content is added to a zone, the system stores the information in the database along with the respective
page template object, not in the actual code of the ASPX page. Communication with the database is ensured by the CMS
PortalManager control, which is located on the Root.master page.

7. Switch to the code behind file (TwoZones.aspx.cs) and add a reference to the CMS.UIControls namespace:

usi ng CMVS. U Controls;

8. Modify the class definition to inherit from the TemplatePage class:

public partial class CMSTenpl at es_Cor porateSite_TwoZones : Tenpl at ePage

9. Save the web form's files.

You can now use the web form as a page template in Kentico.

Registering the ASPX page as a page template

. Log in to the Kentico administration interface and open the Page templates application.

. Select the Corporate Site/Examples folder.

Click New template and type Two zone template into the Template display name field.

. Click Save. The system creates the template and displays its General tab.

. Select the ASPX + Portal page option for the Template type property. This is necessary in order for the Design tab to be available
when editing pages using the template in the Pages application.
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New template = § DB

All page templates
Ad-hoc

Avrticles

Blank

Blank pages for widgets
Blogs

000000

Corporate Site

© Examples

A/B test example page template
Corporate Site - Development r
Corporate Site - Development r
Corporate Site - Development r
Corporate Site - Mobile develop
Corporate Site - Mobile develop
Corporate Site - Mobile develop
Corporate Site - Mobile develop
Corporate Site - Mobile develop
Corporate Site - Mobile develop
Corporate Site - Responsive Ma
Corporate Site - Web Part (sam

Two zone template

© Mobile

Design Layout Sites Scopes Web parts Header Documents Versions
Template display name:* Two zone template
Template code name:* TwoZoneTemplate e
Category: Examples
Template description:
e
Thumbnail: Image v
Upload file
(Template type: ASPX + Portal page v ]
File name: ~/CMSTemplates/CorporateSite/TwoZones.aspx Select Clear

6. Enter the following path into the File name field: ~/CMSTemplates/CorporateSite/TwoZones.aspx
7. Save the changes.
8. Switch to the Sites tab and use the Add sites button to assign the page template to the site that you are using (Corporate Site).

Using ASPX + Portal engine templates

We will modify the About Us page created in the previous example to use the new page template.
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. Open the Pages application.

. Select the About Us page and switch to the Properties -> Template tab.

. Click Select and choose the Corporate Site/Examples/Two zone template page template from the catalog.

. Click Save to confirm the page template change.

. Refresh your browser window and switch to the Design tab, which is now available for the About Us page. You can see two empty

zones on the page as defined in the ASPX code of the template. To define the content of standard zones, add web parts.

. Drag the Editable text web part from the toolbar into zoneRight

. Double-click the web part header in the zone and set the following properties:
® Design -> Editable region title: Right text
® Design -> Editable region height: 400

8. Click Save & Close.

This web part provides a text area on the page that users can edit on the Page tab of the Pages application, just like the editable regions in
the previous example. The template allows you to build the design of the page using a browserbased interface. Each web part zone may
contain any number of web parts.

You may also configure zones to use various types of widgets, which are objects similar to web parts, but allow page customization by
different kinds of website users, not just the administrators or designers.

1. Expand the menu ( E) of zoneLeft and select Configure.



Page Design Form Properties 4 Analytics 4 ~| Web part content

Global Administrator (administrator) Sign in to Administration. The default account is administrator with blank password.

O IT Company

Home Products News Community Services Company Media

= =zoneRight

editabletext

Configure
Add new web part

Move web parts to...

Copy all

Paste

Remove all web parts

. Switch the Widget zone type property from None to Customization by page editor.

. Click Save & Close. The zone now serves as a widget zone for page editors.

. Switch to the Page tab

Type some content into the editable text region displayed by the web part on the right and click Save.
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. Open the menu of the editor widget zone (click == ) and click Add new widget. Select the Newsletters -> Newsletter
subscription widget from the catalog and set the following values for its properties:

* Newsletter name: Corporate Newsletter

® Allow user subscribers: disabled (unchecked)

® \Widget container: Corporate site - Light gradient box

® Widget container title: Newsletter subscription

7. Click Save & Close to add the widget and then Save the page.

The widget provides a form which users can use to subscribe to the site's newsletter.

Page Design Form Properties 4 Analytics 4

Spell check Apply workflow

[ source @ @ G- Qb3 L, B I US % x* ==

Il
1]
%
X

=] F =0 @ %@ [ st - Format - Font - Size -
Sign in to The default account is administrator with blank password. Global Administrator (admlmsﬂa{or)
W Shopping cart | My account | My
Q IT cOmpa ny Your shopping cart is empty
Text size:= m W
Home Products News Community Services Company Media
- I O
First Name:
‘This is an editable region provided by a web part.|
Last Name: :
E-mail:

The example demonstrates how to use web parts or widgets to build the design of pages based on ASPX page templates. This approach
combines the standard architecture and development process of ASPX templates with the flexibility and userfriendliness of the portal engine.

Walkthrough - Creating a new site using ASPX templates



This part of the tutorial guides you through the creation of a simple website. You will learn how to:
® Define site structure and design
® Create your own page templates and pages

The tutorial uses a static website template that is similar to what a developer gets from a graphic designer.

Click to download the sample web template

The template consists of the home.htm file, a styles folder and an app_themes folder with images.

Our Business, Inc.

Home Page 1

Welcome to Our Business, Inc. Web Site Our Business, Inc.
127 One Business Way
This is a sample website design that will help you understand how to convert a site Loz Angeles, CA

template into a master page in Kentico.
phone: (800} 111 1111

How to convert a website template into a master page e (L T €T

The procedure iz simple:

1. Create a new site.
2. Open the Pages application.
3. Click the root document in the content free, which is the master page.
4. Switch to the Design tab, right-click the green template header and click Edit
layout in the menu.
. Copy the HTML code from the static page inte the layout.
. Insert web part zone tags whereever you want to display dynamic content,
such as editable regions, menus, news, efc.
7. Click Save & Close.
8. Add web paris with the required content into the web part zones.
9. Remember to place one Page placeholder web part onto the master page
template, so you can nest sub-pages.
10. Open the CS5 stylesheets application, and copy the required CS5 styles
into your website's stylesheet.

@

‘You're done. Mow you can continue by creating sub-pages.

Creating a new website using the New site wizard (ASPX)

The following pages assume that you have previously installed the sample Corporate Site (running on the localhost domain). Leave the
existing website and add a new site running under the 127.0.0.1 domain.

Multiple sites and Visual Studio's built-in web server
If you are using the built-in web server in Visual Studio instead of 1IS, you need to Stop ( | ) the Corporate Site site in the Sites

application. The built-in web server doesn't support any domain other than localhost, so you need to use the localhost domain ag
ain for the new site.

1. Log in to the Kentico administration interface as administrator and open the Sites application.

2. Click New site wizard.

te Site Si

Import site or objects View export history
= Actions Site name & Status Main domain Documents Default culture
+ 1 ® B B Corporate Site Running localhost 572 BS English - United States

Items perpage | 25 ¥

The New site wizard opens.


https://docs.kentico.com/download/attachments/58339547/SampleWebTemplate.zip?version=1&modificationDate=1394196859133&api=v2

3. Select Create a new site using a wizard and click Next.
4. Enter the following details for the website:

Site display name: My website

Site code name: mysite

Domain name: 127.0.0.1 (if you are using Visual Studio built-in web server, set the Domain name value to localhost)

Site culture: English - United States (the default culture determines how the website displays date, time and numeric values based
on the different culture-specific format)

Click Next.

5. The third step of the wizard allows you to select which objects the system imports into the new site. Do not change anything and click Ne
xt.

The fourth step displays the progress of the object import.

6. Choose a master page template for the website. You can change it later at any time. For now, select the Blank master page.

Step 50f 6 = Select master page

The master page defines the layout of the main menu, logo and content placeholders. You can change it at any time later.

Blank master page
Generic default page template.
Corporate Site - Master page

Corporate Site - Mobile development - CMSConditionalLayout (Master)

Corporate Site - Mobile development - CMSDevicelLayout (Master)

Click Next. This concludes the initial process of creating the website.
7. Click Edit your new website.

The system opens a new tab with the Kentico administration interface using the 127.0.0.1 domain. You need to sign in again (user name ad
ministrator, blank password) since authentication is not shared over different domains by default.

Creating a CSS stylesheet (ASPX)

Before you start editing your new website, prepare a new CSS stylesheet based on the styles and images of the sample website template.
1. Open the CSS stylesheets application.
2. Click New CSS stylesheet.
3. Enter the following values:
® Display name: My site stylesheet
® Code name: MySite
® Code: copy and paste all CSS code from the Sample web template - SampleWebTemplate\Styles\main.css
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~No oh~

General
Display name:* My site stylesheet
Code name:* MySite
~| assign to website My website
Code
/% -—-- News page ——-— */

NewsTitle

: #3cT8cc;

ont-size: large;

.NewsSummary

op: 3px;

bottom: 3px;

: bold;

/* -—-- Drop-down menu ---— */

subCMS3Menultem, .subCMSMenultemMouseCver, .subCM3MenultemMouseDown,

1 #3a75ca;

text-decoration: none;
width: 90px

1
CFEHE >a RS |

= |

. subCMSMenultemMouselUp, .

. Click Save.
. Switch to the Sites tab and assign the stylesheet to My website.

. Open the Sites application and edit ( # ) My website.
. On the General tab, select My site stylesheet as the Site CSS stylesheet.




General

Site display name:*
Site code name:”
Site domain name:”

Site description:

Cultures

Default content culture:

Visitor culture:

Style sheets

Site C55 stylesheet:

Editor CS5 stylesheet:

My website

mysite

127.00.1

Sample blank web site

English - United States

(Automatic)

My site stylesheet

(site stylesheet)

Change
Edit New
Edit MNew

8. Click Save. This ensures that all pages of your new website load the appropriate stylesheet.
9. Copy the SampleWebTemplate\app_themes\MySite folder to the CMS\App_Themes folder in your web project (c:\inetpub\wwwro

ot\Kentico by default).

The folder contains graphics for the website template. The App_Themes location ensures that the images are exported as part of the website
if you decide to move the website in the future. The folder under App_Themes must have the same name as the code name of the CSS

stylesheet: MySite.

CSS stylesheet URL and relative paths

The image paths in the sample CSS stylesheet already match the target folders in your new website. In real-world scenarios, you
will need to adjust the paths manually. The URLs of images in the CSS stylesheets are always relative to the location of the

web project.

The URL of the CSS stylesheet is:

<web project>/CMSPages/GetResource.ashx?stylesheetname=MySite

which means that you need to link to files in the App_Themes folder like in the example below:

/app_themes/mysite/images/imagename.gif



Opening and configuring the web project (ASPX)

Open your Kentico web project in Visual Studio. Use the WebSite.sIn or WebApp.sin file in the website installation directory ( c:\inetpub\ww
wroot\Kentico by default).

Adding Kentico controls to the Visual Studio Toolbox

To make it easier to work with Kentico components on your ASPX pages, add the built-in set of controls to your Visual Studio Toolbox.

1. Edit any ASPX web form file, for example Default.aspx under the project root. This is necessary, because the toolbox only offers the
controls when working with ASPX markup.

. Right-click the Toolbox and choose Add Tab.

Type the name of the new tab (for example Kentico) and press Enter.

. Right-click the new tab and select Choose Items.

. Click Browse on the .NET Framework Components tab of the Choose Toolbox Items dialog.

. Navigate to the CMS\bin folder under your website.

. Select the CMS.Controls.dll library.

. Click Open and then OK.
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The controls are now added to the Toolbox. You can drag and drop the controls onto your Web forms.

Developing the master page (ASPX)

Create a master page for the website containing a header, navigation menu and footer. This master page will be shared by all ASPX
templates used to build the site's pages.

Open your web project in Visual Studio. Right-click the CMSTemplates folder in the Solution Explorer and select New Folder. Name the
folder MySite.

We recommend using a folder name that matches the code name of your site. This ensures that the system exports/imports the
folder's content along with the website when you deploy it to another instance of Kentico.

Adding the master page

Right-click the MySite folder, select Add -> Add New item.

. Create a Master page named MyMaster.master.

Delete all default ASPX code of the master page (in the Source view) except for the first line with the <% @ Master %> directive
. Add the following code instead:

rPONE

<%DocType%
<htm xm ns="http://ww. w3. org/ 1999/ xhtm ">

<head i d="Headl" runat="server">

<title id="Titlel" runat="server">W website</title>

<asp:literal runat="server" id="ItlTags" enabl evi ewstate="fal se" />
</ head>

<body cl ass="<%BodyCl ass%" <% BodyPar anet er s¥%>
<formid="fornl" runat="server">
<asp: Pl aceHol der runat ="server" |D="pl cManagers">
<aj axTool ki t: Tool ki t Scri pt Manager | D="nmanScript" runat="server"
Enabl eVi ewSt at e="f al se" Scri pt Mode="Rel ease" />
<cns: CVSPor t al Manager | D="CMsPort al Manager 1" runat ="server" />
</ asp: Pl aceHol der >
</forne
</ body>

</htm >

® The ToolkitScriptManager control allows AJAX components to work on the pages of your site (required).
® The CMSPortalManager control ensures the loading and saving of content between the database and editable
regions. It also provides the management necessary for web part or widget zones defined on child ASPX pages.



5. Open the home.htm file (from the Sample web template) and copy the HTML code from inside the <body>...</body> tags. Paste
this code into the body of the master page after the <asp:PlaceHolder> control.
6. Delete all code in the <!-- main content --> ... <!-- /main content --> section and replace it with the following control:

<asp: Cont ent Pl aceHol der | D="pl cMai n" runat="server"></asp: Cont ent Pl aceHol der >

Because you are creating a master page, you do not need the actual content of the Home page, only the logo, main menu
and footer. The replacement code adds a standard ASP.NET control that ensures the loading of pages inside the master
page.

The code of the master page's <body> element should now look like this:

<body cl ass="<%Bodyd ass%" <% BodyPar anet er s%>
<formid="fornl" runat="server">
<asp: Pl aceHol der runat="server" |D="pl cManagers">
<aj axTool ki t: Tool ki t Scri pt Manager | D="nmanScript" runat="server"
Enabl eVi ewSt at e="f al se" Scri pt Mode="Rel ease" />
<cns: CVMSPor t al Manager | D="CMsPort al Manager 1" runat ="server" />
</ asp: Pl aceHol der >

<di v class="Mai nDi v">

<l-- logo -->

<br />

<div class="Logo">
&nbsp;

</ div>

<l-- main nmenu -->

<di v cl ass="Mai nMenu" >
<t abl e cel | spaci ng="2" cel | paddi ng="2" border="0">
<tr>
<td cl ass="Mai nCMSMenuH ghl i ght edMenul t ent >Hone</t d>
<td cl ass="Mai nCMsMenul t ent >Page 1</t d>
</tr>

</tabl e>
</ di v>

<!-- pain content -->

<asp: Cont ent Pl aceHol der | D="pl cMai n"
runat =" server" ></ asp: Cont ent Pl aceHol der >

<!-- /main content -->

<l-- footer -->
<div class="Footer">
This is a sanple Kentico website
</ di v>
</ div>
</forme
</ body>

Adjusting the master page code behind

1. Edit the code behind of the master page (MyMaster.master.cs).
2. Add a reference to the CMS.UIControls namespace:

using CVS. U Controls;
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3. Change the class definition so that the master page inherits from the TemplateMasterPage class:

public partial class CMSTenpl ates_MSite My/Master : Tenpl at eMast er Page

4. Override the CreateChildControls method in the class according to the following code:

protected override void CreateChildControl s()

{
base. Creat eChi | dControl s();

PageManager = CMSPort al Manager 1;

5. Add an override for the OnPreRender method:

protected override void OnPreRender (Event Args e)

{
base. OnPr eRender (e);

this.Itl Tags. Text = this. Header Tags;

6. Save the master page files.

Continue editing the master page according to the instructions in Creating the main menu (ASPX).

Creating the main menu (ASPX)

Now add a dynamic drop-down menu to the master page. You can implement the drop-down menu using either the CMSMenu or CMSListM
enu control. The example uses the first option, which is easier to understand if you are not familiar with advanced CSS styles.

If you prefer a drop-down menu based on CSS styles and UL/LI elements, you can try using the CMSListMenu later. See the Contr
ols Reference for additional details and examples.

1. Edit the MyMaster.master file in Visual Studio.

2. Remove the <table> element used as a static menu inside the <div class="MainMenu"> element. Instead, drag the CMSMenu con
trol from the toolbox to this location.

3. Set the following properties of the CMSMenu control (you can find them in the Behavior section of the Visual Studio Properties win

dow):

Property  Value Description

Path 1% Configures the menu to display pages starting from the root of the site structure.

Layout Horizontal = Sets a horizontal layout for the menu.

CSSPrefix  ;sub Allows you to add prefixes before the names of the CSS classes applied to the menu. The ;sub value
uses unmodified class names for the main (first) menu level and the sub prefix for the second level and
all other sub-levels.

Cursor Pointer Specifies the type of mouse cursor displayed when a user hovers over the menu.

4. Save the changes.

The code of the main menu section should now look like this:

<l-- main nenu -->
<di v cl ass="Mi nMenu" >
<cns: CMSMenu | D="CVSMenul" runat="server" Path="/9% Layout="Horizontal"
CSSPr ef i x="; sub" Cursor="Pointer" />
</ di v>

The master page is now prepared and you can assign it to the site's ASPX templates. Continue with Developing the Home page (ASPX)
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Kentico Controls and Web Parts

Kentico provides a set of flexible server controls in the CMS.Controls.dll library, but large amounts of the built-in functionality are
only available through web parts stored in the CMSWebParts folder.

These web parts are standard ASCX user controls and you can use them on both portal engine templates and ASPX pages. To
add a web part onto your ASPX pages, drag it from the Solution explorer and set the properties in the Properties window.

Developing the Home page (ASPX)

This page describes how to create the home page of the website. The process consists of the following steps:

Preparing the ASPX source file

Registering the page template in the system
Adding the Home page

Editing the content of the Home page
Choosing the website's home page

Preparing the ASPX source file
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. Edit your web project in Visual Studio

. Right-click the CMSTemplates/MySite folder in the Solution Explorer and click Add -> Add New Item.

. Create a Web Form named Home.aspx and check Select master page.

. Click Add and choose the MyMaster.master page from the CMSTemplates/MySite folder.

. Open the home.htm file (from the Sample web template) and copy the HTML code from inside the <!-- main content --> section.

Paste this code inside the <asp:Content> element of the Home.aspx file.

. Remove the static text content from the page:

® The "Welcome to Our Business, Inc. Web Site..." text inside the table in the <!-- center box --> section
® The "Our Business, Inc. ..." text in the <!-- right column --> section

The content of the web form should now match the following:


https://docs.kentico.com/download/attachments/58339547/SampleWebTemplate.zip?version=1&modificationDate=1394196859133&api=v2

<asp: Content | D="Content1l" ContentPl aceHol derl D="pl cMai n" Runat ="Server">

<!-- pmain content -->
<tabl e styl e="wi dt h: 100% hei ght : 500px; border: Opx">
<tr style="vertical-align:top;">

<l-- left colum -->

<td styl e="w dt h: 280px" cl ass="HonePagelLeft Col uim" >

</td>

<!-- center colum -->

<td styl e="paddi ng: 3px 5px Opx 5px;w dt h: 450px; ">
<l-- center box -->

<t abl e cel | spaci ng="0" cel | paddi ng="0" border="0"
cl ass="Cont ai ner Wt hCorners" w dt h="100% >

<tr class="Contai ner Wt hCor ner sRow' >
<td cl ass="Cont ai ner Wt hCor ner sTopLeft">&nbsp; </ td>
<td cl ass="Cont ai ner Wt hCor ner sTop" >&nbsp; </ td>
<td cl ass="Cont ai ner Wt hCor ner sTopRi ght " >&nbsp; </t d>

</tr>

<tr>
<td cl ass="Cont ai ner Wt hCor nersLeft">&nbsp; </td>
<td cl ass="Cont ai ner Wt hCornersContent" valign="top">

</td>
<td cl ass="Cont ai ner Wt hCor ner sRi ght " >&nbsp; </t d>
</[tr>
<tr cl ass="Cont ai ner Wt hCor ner sRow" >
<td cl ass="Cont ai ner Wt hCor ner sBot t omLeft" >&nbsp; </t d>
<td cl ass="Cont ai ner Wt hCor ner sBot t ont' ></ t d>
<td cl ass="Cont ai ner Wt hCor ner sBot t onRi ght " >&nbsp; </t d>

</tr>
</tabl e>
</td>
<l-- right colum -->
<td styl e="paddi ng: 3px Opx Opx 5px;w dth: 270px" >
<l-- text box -->

<t abl e cel | paddi ng="0" cel | spaci ng="0" style="wi dt h:
100% mar gi n-bottom 10px;" cl ass="Bl ue">

<tr>
<td cl ass="BoxTitle">Contact us
</td>

</[tr>

<tr>
<td cl ass="BoxArea">

</td>
</[tr>
</t abl e>
</td>
<[tr>
</t abl e>
<l-- /main content -->

</ asp: Cont ent >

Replace the text with editable regions so that content editors can manage the page in the Kentico administration interface.

1. Modify the code of the table in the <!-- center box --> section according to the following:



<l-- center box -->
<tabl e cel | spaci ng="0" cel | paddi ng="0" border="0" cl ass="Cont ai ner Wt hCor ners"
style="wi dth: 100% ">
<tr cl ass="Cont ai ner Wt hCor ner sRow" >
<td cl ass="Cont ai ner Wt hCor nersTopLeft">&nbsp; </ td>
<td cl ass="Cont ai ner Wt hCor ner sTop" >&nbsp; </t d>
<td cl ass="Cont ai ner Wt hCor ner sTopRi ght " >&nbsp; </t d>
</tr>
<tr>
<td cl ass="Cont ai ner Wt hCor nersLeft">&nbsp; </td>
<td cl ass="Cont ai ner Wt hCor nersContent" valign="top">
<cns: CVSPagePl acehol der | D="pl cZone" runat="server">
<Layout Tenpl at e>
<cms: CVs\WebPart Zone | D="zoneMai n" runat="server" />
</ Layout Tenpl at e>
</ cns: CMSPagePl acehol der >
</td>
<td cl ass="Cont ai ner Wt hCor ner sRi ght " >&nbsp; </t d>
</[tr>
<tr cl ass="Cont ai ner Wt hCor ner sRow" >
<td cl ass="Cont ai ner Wt hCor ner sBot t onlLeft">&nbsp; </ td>
<td cl ass="Cont ai ner Wt hCor ner sBot t on{' ></ t d>
<td cl ass="Cont ai ner Wt hCor ner sBot t onRi ght " >&nbsp; </t d>
</tr>
</tabl e>

The CMSPagePlaceholder control (added to the center cell of the middle row) defines an area of the page that users can
modify through their browser. Later, you will configure this area to allow content editors to customize the design of the
Home page.

2. Switch to the Design tab and drag a CMSEditableRegion control from the toolbox into the bottom cell of the table on the right of the
page.
3. Set the following properties of the CMSEditableRegion control:
® |D: txtRight
® DialogHeight: 280
® RegionTitle: Right content
® RegionType: HtmlEditor

4. Switch to the code behind of the home page (Home.aspx.cs) and add a reference to the CMS.UIControls namespace:

using CVS. U Controls;

5. Change the class definition so that it inherits from the TemplatePage class:

public partial class CMSTenpl ates_MSite _Hone : Tenpl at ePage

6. Save the home page files.

Registering the page template in the system

The source files of the home page are ready. Now you need to register the home page template in Kentico.

. Open Kentico in a web browser and log in to the administration interface (default username administrator with an empty password).
. Open the Page templates application.

Click ... next to the New template button and select New category.

Type My website into the Category display name field.

. Click Save.

. Click New template and type Home page into the Template display name field.
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7. Click Save.
8. Set the following values on the General tab:
®* Template type: ASPX + Portal page
® File name: ~/CMSTemplates/MySite/Home.aspx

9. Click Save.
10. Switch to the Sites tab and assign the page template to My website.
7 - i B General Design Layout Sites Scopes Web parts Header Documents. Versions
@ All page templates m
@ Ad-hoc
© Artices Template display name:* Home page
@ Blank
© Blank pages for widgets Template code name:* HomePage (2]
© Blogs
© Corporate Site Category: My website
© Dashboard pages
© Events Template description:
© FAQs 4
© Forums Thumbnail: Image v
@ General
@ Home pages Upload file
© Images —
© Job openings Template type: ASPX page Y
@ Knowledge base
© Master templates File name: ~/CMSTemplates/MySite/Home.aspx ﬂ ﬂ'
© Membership and security
@ My website
Home page
© News
©  Newsletter

Adding the Home page

. Open the Pages application.
. Select the root of the content tree (My website).

. Click New (F).
. Choose the Page (menu item) page type.

. Type in Home as the Page name and choose the Use existing page template option. Select the My website category and the Ho
me page template.
. Click Save to create the page.

abhw N

2]

Editing the content of the Home page

1. With the Home page selected, switch to the Design tab. Here you can see the editable area that you defined in the code of the page
template.
2. Right-click the header of the zoneMain zone and select Configure in the menu.

Page Design Form Properties 4 Analytics 4

Our Business, Inc.

= e e —

= zoneMain

Configure
Add new web part

Move web parts to...

Copy all

Paste

Remove all web parts

3. Switch the value of the Widget zone type property from None to Customization by page editor and click Save & Close.



4. Open the Page tab, expand the widget zone's menu (=) and click Add new widget.
a. Select the General -> Text widget.
b. Click Select.
c. Type Welcome to our website! into the Text property
d. Click Save & Close.

Page Design Form Properties 4 Analytics 4

m Spell check Apply workflow

[ source HE e Qb L BI USHMXOUYX Z:= €9 Y% === L= ™ Bm
Styles - Format - Font - size ~ A- B~ {# X A
Our Business, Inc.

| Right content

You can modify the design of the page directly through the browser by adding and configuring widgets. This approach can
be useful once the website has some more content or features to be displayed.

5. Type the following text into the Right content editable region: Call 800 111 2222

6. Click Save. You always need to click Save to confirm changes made to the text of editable regions or widget content on the Page ta
b.

Switch to Preview mode to see how the home page of your website appears to visitors.

Choosing the website's home page

When a visitor arrives at the root URL of the website (i.e. its domain name, for example http://www.example.com), the system needs to know
which page to display as the home page.

To set the path of the website's default home page:

. Open the Settings application.

. Select the Content category in the settings tree.

. Select My website in the Site drop-down.

. Clear the Inherit from global settings check box next to the Default alias path setting.
. Type in /[Home, which is the alias path of your new home page.

. Click Save.
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Site: Export these settings
My website &)
Multilingual
© Settings
© Content Default content culture: Inherit from global settings
URLs and SEO
- U v
©  Security & Membership English - United States o
Syst

© System Combine with default +| Inherit from global settings
@  On-line marketing culture:
© E-commerce 7]
©  Community Combine files with default v Inherit from global settings
@ Social media culture:
©  Social marketing v @
© Intranet & Collaberation
© Versioning & Synchronization Web site content
© Integration

Default alias path: Inherit from global settings

/Home Select
Metadata

When visitors access the website without specifying the URL of a particular page, the system automatically displays the Home page.

Developing the News page (ASPX)

Create the News section of the website.

Preparing the ASPX source file

. Edit your web project in Visual Studio.

. Right-click the CMSTemplates/MySite folder in the Solution Explorer and click Add -> Add New ltem.
. Create a Web Form named NewsPage.aspx and check Select master page.

. Click Add and choose the MyMaster.master page from the CMSTemplates/MySite folder.

. Drag the following controls inside the <asp:Content> element of the news page:
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® CMSBreadCrumbs
® CMSRepeater

6. Set the properties of the CMSRepeater control according to the table below (you can find them in the Behavior section of the Visual
Studio Properties window):

Property Value Description
ClassNames cms.news Configures the repeater to display only pages of the cms.news type.
TransformationName cms.news.preview  Assigns the transformation that the repeater uses to display the list of

news items.

When a user selects a specific news item on the website, the repeater
displays the details according to the specified transformation.

SelectedltemTransformationName cms.news.default

IltemSeparator <hr /> Defines the HTML code placed between individual news items in the list.



<cns: CVSRepeat er | D="CMSRepeat er 1" runat ="server" C assNanes="cns. news"
Transf or mati onNane="cns. news. previ ew'
Sel ect edl t emilr ansf or mati onNanme="cns. news. defaul t" |tenSeparator="<hr />" [>

7. Add the following HTML code between the two controls:

<hl1>News</ h1>

8. Switch to the code behind of the news page (NewsPage.aspx.cs) and add a reference to the CMS.UIControls namespace:

using CVS. U Controls;

9. Change the class definition so that it inherits from the TemplatePage class:

public partial class CMSTenpl ates_M/Site_NewsPage : Tenpl at ePage

10. Save the news page files.

Registering the page template

The source files of the news page are ready. Now you need to register the page template in Kentico.

. Switch to the Kentico administration interface in your browser.

. Open the Page templates application.

. Select the My website category.

. Click New template and type My news template into the Template display name field.
Click Save.

. Set the following values on the General tab:

®* Template type: ASPX page

® File name: ~/CMSTemplates/MySite/NewsPage.aspx

OUAWN R

7. Click Save.
8. Switch to the Sites tab and assign the page template to My website.

Adding the news section

. Open the Pages application.

. Select the root of the content tree (My website).
. Click New ().

. Choose the Page (menu item) page type.

asrw NP

news template page template.

. Type in News as the Page name and choose the Use existing page template option. Select the My website category and the My



m Provi Listing Save and create another

+ 0 B~ v P

Page name: | News

© IR My website o ®) Use existing page template Use parent page template Create a blank page with layout Create a blank page
B Home (]
© All page templates o
Articles
Blogs
Events
FAQs ] I
Forums I . I .
Home pages
Home page My news template

Images

Job openings

Knowledge base

General

Master templates
Membership and security
My website

News

. Click Save to create the page.
. Select the News page in the content tree

. Click New ( + ) and choose the News page type.
. Fill'in the news page fields with the following values:
* News Title: News 1
Release Date: click Today
News Summary: News 1 summary.
News Text: News 1 text.
Publish from/Publish to: leave the fields blank
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10. Click Save and create another and enter the following values:
® News Title: News 2
® Release Date: click Today
® News Summary: News 2 summary.
®* News Text: News 2 text.
® Publish from/Publish to: leave the fields blank

11. Click Save.

If you select the /News page and switch to Preview mode, you can see a list of all news pages placed under the News section.

Our Business, Inc.

News

News

News 1

MNews 1 summary.

News 2

News 2 summary.

This is an example of how content is structured in Kentico. If you select a specific news item, the page displays the detail view.

The breadcrumbs at the top of the page show the current path on the website: News > News 1. The position is also reflected in the default
page URLs:

® The URL of the News page is ~/news.aspx
® The URL of the News 1 page is ~/news/news-1.aspx

This makes the website accessible to both people and search engines.

How it works

1. A visitor arrives on the /News page.
2. The CMSRepeater control placed on the page template checks if a news page is currently selected (based on the value of the Clas



sNames property).

3. The control finds out that the current page is a page (menu item), so it looks for all underlying news pages and displays them as a
list using the cms.news.preview transformation.

4. When the visitor selects a particular news item, such as /News/News 1, the repeater control uses the cms.news.default transforma
tion instead to display the details.

Path expressions

Listing web parts and controls have the Path property that specifies which content the component loads and displays. The following
expressions are examples that you can use to select pages:

Path expression  Meaning

1% All pages on the website.
/news/% All pages under /News.
/news/news1 The Newsl1 page.
1% All items under the current page.
Jlogo The Logo page under the current page.
/images/% All pages under the Images page, which is a child of the current page.
../contacts/% All pages under the Contacts page on the same content level as the current page.
{0}/% All pages under the page located on the first level of the current path.
Example:

If the currently selected page is:
/news/news1
the system evaluates the expression as:

/Inews/%

Developing the Services page (ASPX)

Create a website section for services. The page template used for this section will contain a tree menu on the left and a single editable
region.

Preparing the ASPX source file

. Edit your web project in Visual Studio

. Right-click the CMSTemplates/MySite folder in the Solution Explorer and click Add -> Add New ltem.
. Create a Web Form named LeftMenuRightText.aspx and check Select master page.

. Click Add and choose the MyMaster.master page from the CMSTemplates/MySite folder.

. Enter the following HTML layout code into the <asp:Content> element on the page:
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<table style="width: 100% ">
<tr style="vertical-align: top;">
<td style="width: 20%">

</td>
<td style="width: 80% ">

</td>
</[tr>
</t abl e>

6. Drag the CMSTreeMenu control into the first table cell and the CMSEditableRegion control into the second cell.
7. Set the following properties for the controls:

CMSTreeMenu:

Property Value Description



10.

Path 1{0}/% Configures the tree menu to display pages starting from the
second level of the currently selected path.

MenultemlmageURL ~lapp_themes/mysite/images/bullet.gif = Sets the path of the image displayed next to items in the

tree menu.

The ~ character represents the root of the website. This
relative path ensures that the control displays the image
correctly even if the website's virtual directory name

changes.

MenultemOpenimageURL ~/app_themes/mysite/images/bullet.gif ~Specifies the image displayed next to items in the tree menu
that belong on the path of the currently selected page.

CMSEditableRegion:

Property Value Description

RegionType HTMLEditor Determines which type of editing interface the control provides. With this option, the editable region

works as a WYSIWYG HTML editor.

DialogHeight 400 Sets the height of the editable region in pixels.

RegionTitle Main Text Specifies the title displayed in the header of the editable region on the Page tab of the Pages

application in the Kentico administration interface.

ace:

usi ng CMS. Ul Control s;

. Change the class definition so that it inherits from the TemplatePage class:

public partial class CMSTenpl ates_MSite_Left MenuRi ght Text

Save the files.

Registering the page template

The source files of the services page are ready. Now you need to register the page template in Kentico.
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. Switch to the Kentico administration interface in your browser.

. Open the Page templates application.

. Select the My website category.

. Click New template and type Left menu with right text into the Template display name field.

Click Save.

. Set the following values on the General tab:

®* Template type: ASPX page
® File name: ~/CMSTemplates/MySite/LeftMenuRightText.aspx

. Click Save.
. Switch to the Sites tab and assign the page template to My website.

Adding the services section

Now that the page template is ready, you can start adding pages based on it.
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6.

. Open the Pages application.
. Select the root of the content tree (My website).

. Click New ( F).
. Choose the Page (menu item) page type.
. Type in Services as the Page name and choose the Use existing page template option. Select the My website category and the

Left menu with right text page template.
Click Save to create the page.

. Switch to the code behind of the services page (LeftMenuRightText.aspx.cs) and add a reference to the CMS.UIControls namesp

Tenpl at ePage

The Page tab of the Services page opens, where you can enter text content into the editable region on the right.



Preview Listing Page Form Properties 4 Analytics 4

+ i § BE A~ v O Spell check Apply workflow
Ol My website <@ [ gource B @ E % « Qb3 L B I US x x°
E Home © Styles ~  Format - Font - size - A- B- {8 22 =l
© B News ]
© B Services ]
B Service 1 ]
B Service 2 ]

P Service 1 : Main Text

- \This page provides an overview of our service|
P service 2 : pags P |

Creating sub-pages

You can use the same page template to add separate pages containing information about individual services under the Services page.

. In the Pages application, select the /Services page.

. Click New ( ).

. Choose the Page (menu item) page type.

. Type in Service 1 as the Page name and choose the Use existing page template option. Select the My website category and the
Left menu with right text page template.

5. Click Save and create another and repeat the same process to add any number of pages dedicated to particular services.
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All of the service pages use the same template as the main overview page (/Services). The page template provides the tree menu for
navigation in the services section and an editable region. The system stores the text of the region separately for every page, so you can
enter unique content on each page.

Developing the Products section (ASPX)

Now we will add a products section displaying a list of computers and their technical specifications. You will learn how to:

1. Create a new page type representing computer products
2. Write transformations
3. Create a page displaying a list of computer products

Defining a new page type (ASPX)

Each page in Kentico is of a certain type, such as page, news, product, article, etc. Every page type has its own data fields. The page type
describing computer products will have fields storing the computer name, processor type, RAM size, disk size and product image.
1. Open the Page types application.
2. Click New page type. This starts the New page type wizard.
3. Enter the following values in Step 1:
® Page type display name: Computer (the system displays this name to users in the administration interface)
®* Namespace: custom (namespace to distinguish your page types from the default system types that use the cms
namespace)
®* Name: computer (the identifier of the page type)



Steplof7 | General

Please enter page type display name (for users) and code name (it will be used in your code when necessary).

Page type display name: Computer

Page type code name:
Namespace: custom

Name: computer

. Click Next.

. In Step 2, specify the name of the database table where the system stores the data of computer pages. You also need to enter the
name of the table's primary key field. Leave the default values.

. Click Next. The system creates a new database table for computer pages.

. In Step 3, you need to define the fields of the page type (columns of the table). Click New field to create the following fields. For
each field, enter the values, click Save and repeat the procedure until you have defined all the listed fields.

Field name: ComputerName
Data type: Text

Size: 200

Required: yes (checked)

Field caption: Computer name
Form control: Text box

Field name: ComputerProcessorType

Data type: Text

Size: 200

Field caption: Processor type

Form control: Drop-down list

Editing control settings -> Data source: select List of options and enter the following items into the text area, one per
line:

At hl on; At hl on
Pent i um XEON; Pent i um XEON
Penti um Core 2 Duo; Pentium Core 2 Duo

Field name: ComputerRamSize
Data type: Integer number
Field caption: RAM (MB)

Form control: Text box

Field name: ComputerHddSize
Data type: Integer number
Field caption: HDD (GB)
Form control: Text box

Field name: Computerimage
Data type: File

Field caption: Image

Form control: Upload file



10.
11.

12.

13.

14.
15.

Step3of 7 | Fields

Please define custom fields of the page type and their appearance in the editing form. You can define fields, such as product number, product
weight, press release text, etc.

Newfield | = ® ~ W Field type: | File

Required:
ComputerName
ComputerProcessorType
ComputerRamSize
ComputerHddSize
New field

Translate field:

GUID:

~| Display field in the editing form

Field appearance
Field caption: P | Image

Field description: P

Explanation text: p

Form control: Upload file v

. Click Next.
. In Step 4, choose the ComputerName field as the Page name source.

This means that when a user creates a new computer page, the system automatically fills in the page name based on the
ComputerName value. The page name appears in site navigation and in the content tree of the Pages application.

Click Next.

In Step 5, select the page types that will be supported as parents for computer pages in the content tree. Click Add page types,
select the Page (menu item) page type and click Select. This means that users are only allowed to place computer pages under
pages, not under articles, news items or other page types.

Click Next.

In Step 6, assign the page type to all websites where you wish to use it. Click Add sites, choose My website in the selection dialog
and click Select.

Click Next.

Click Finish to complete the creation of the new page type.

The wizard automatically creates the database table and several default transformations.

How does the system store page content?

The system stores page content and all related data in three database tables:

® CMS_Tree (content tree structure)
® CMS_Document (general page properties, metadata and editable region content)
* A dedicated page type table - in this case CUSTOM_Computer (stores the values of the page type's specific fields)

Writing transformations (ASPX)

Now that you have created the new page type, you need to prepare the transformations that page components will use to display computer
products on the website.

1.

2.
3.

Open the Page types application.

Edit ( # ) the Computer page type.
Switch to the Transformations tab.



€= New hierarchical transformation
General _

= Actions Transformation name .. Transformation type
Fields # F - Atomitem ASCX
Layout # W = Default ASCY

. * W = Preview ASCX

Transformations s

# W - RSSltem ASCH
Queries

The New page type wizard has created several default transformations, which you can use as a base for your own
transformations.

4. Edit ( s ) the Default transformation, clear the original code and replace it with the following:

<hl>
<%t Eval (" Conput er Nane") %
</ hl>
<t abl e>
<tr>
<td>
Processor:
</td>
<td>
<%t Eval (" Conmput er Processor Type") %
</td>
</[tr>
<tr>
<td>
RAM (VB) :
</td>
<td>
<%t Eval (" Conput er RanfSi ze") %
</td>
</[tr>
<tr>
<td>
HDD ( GB) :
</td>
<td>
<%t Eval (" Conput er HddSi ze") %
</td>
</[tr>
<tr>
<td>
| mage:
</td>
<td>
<% Getlmage(" Conputerl mage") %
</td>
</[tr>

</t abl e>



ASCX transformation code is similar to standard ltemTemplate elements that you may already be familiar with from from
using ASP.NET Repeater or DataList controls. The transformation code combines HTML with ASP.NET commands and
data binding expressions (Eval). You can also use built-in methods that simplify various tasks, such as Getimage. For
more information about the available transformation methods, click the Available transformation methods link above the
code editor.

You will use the Default transformation for displaying the details of individual computer products.

5. Click Save.
6. Return to the transformation list and edit the Preview transformation. Clear the default code and add the following code instead:

<div style="text-align:center;padding: 8px; mrgin: 4px;border: 1px solid
#CCCCCC" >
<h2>
<a href="<% GetDocunentUrl () 9%"><%t Eval (" ConputerNane") %</a>
</ h2>
<0 Getlnmage(" Conputerlnage", 120) %
</ di v>

7. Click Save.

Note the code used to create the link to specific pages. It consists of a standard HTML link tag and inserts the appropriate URL and link text
dynamically:

<a href="<%t GetDocunentUrl () %"><%t Eval (" ConputerNane") %</a>

You can generate an image tag containing the file uploaded into the given page's Computerimage field using the Getimage method. The
sample code calls the method with a parameter that ensures automatic serverside resizing of the image's longest side to 120 pixels:

<%t Cetlmage(" Conputerlmage", 120) %

You will use the Preview transformation for displaying the list of computer pages on the main products page.

Entering field names in transformations

When writing ASCX transformations, you often need to specify the names of data fields as parameters of the Eval data binding
expression or other methods, such as ComputerName and Computerlmage in the examples above.

You can press CTRL + SPACE to access a list of available page fields and related objects instead of typing them manually.

Creating the Products page (ASPX)
This page describes how to create the product list page and publish computer specifications on the website.

Preparing the ASPX source file for the products template

. Edit your web project in Visual Studio.
. Right-click the CMSTemplates/MySite folder in the Solution Explorer and click Add -> Add New ltem.
. Create a Web Form named ProductList.aspx and check Select master page.
. Click Add and choose the MyMaster.master page from the CMSTemplates/MySite folder.
. Drag the following controls inside the <asp:Content> element of the product list page:
¢ CMSBreadCrumbs
¢ CMSDatalist
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6. Set the properties of the CMSDatalL.ist control according to the table below:

Property Value Description

ClassNames custom.computer Configures the datalist to display only pages of the
custom.computer type.



OrderBy ComputerName ASC Sets the SQL ORDER BY clause that the control uses when
loading data. As a result, the control displays items in ascending
alphabetical order based on the ComputerName values.

TransformationName custom.computer.preview Assigns the transformation that the datalist uses to display the
list of computer products.

SelectedltemTransformationName = custom.computer.default ~ When a user selects a specific computer page on the website,
the control displays the details according to the specified
transformation.

RepeatColumns 2 Configures the datalist to display 2 items per row in list mode.

7. Switch to the code behind of the product list page (ProductList.aspx.cs) and add a reference to the CMS.UIControls namespace:

usi ng CVS. U Controls;

8. Change the class definition so that it inherits from the TemplatePage class:

public partial class CMSTenpl ates_MSite_ProductList : Tenpl at ePage

9. Save the files.

Registering the page template

The source files of the products page are ready. Now you need to register the page template in Kentico.

Switch to the Kentico administration interface in your browser.
Open the Page templates application.
Select the My website category.
Click New template and type Product list into the Template display name field.
Click Save.
Set the following values on the General tab:
®* Template type: ASPX page
® File name: ~/CMSTemplates/MySite/ProductList.aspx
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7. Click Save.
8. Switch to the Sites tab and assign the page template to My website.

Adding the products section

. Open the Pages application.
. Select the root of the content tree (My website).

. Click New ( F).

. Choose the Page (menu item) page type.

. Type in Products as the Page name and choose the Use existing page template option. Select the My website category and the
Product list page template.

. Click Save to create the page.

. Select the Products page in the content tree.
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6

7

8. Click New ( + ) and choose the Computer page type.

9. Fill in the computer page fields with the following values:

Computer name: Home PC Dallas

Processor type: Athlon

RAM (MB): 2048

HDD (GB): 160

Image: upload an image (you can find images in the Sample web template - SampleWebTemplate\Computer_Images)
Publish from/Publish to: leave the values blank

10. Click Save and create another and enter the following values:
® Computer name: Office PC Houston
Processor type: Pentium Core 2 Duo
RAM (MB): 4096
HDD (GB): 200
Image: upload an image (you can find images in the Sample web template - SampleWebTemplate\Computer_Images)
Publish from/Publish to: leave the values blank

11. Click Save.


https://docs.kentico.com/download/attachments/58339547/SampleWebTemplate.zip?version=1&modificationDate=1394196859133&api=v2
https://docs.kentico.com/download/attachments/58339547/SampleWebTemplate.zip?version=1&modificationDate=1394196859133&api=v2

If you view the /Products page in Preview mode, you can see a list of the two computer products (formatted according to the custom.compu
ter.preview transformation).

Our Business, Inc.

Home News Products Services

Products

Home PC Dallas Office PC Houston

When you click the title of a specific computer, the page displays the detail view (using the custom.computer.default transformation).

Our Business, Inc.

Home News Products Services

Products = Home PC Dallas

Home PC Dallas

Processor: Athlon
RaM (MB): 2048
HDD (GB). 168

Image:

Developing the Search page (ASPX)

Kentico allows users to perform index-based searches through all page content, as well as other types of data. The following instructions
describe how to add a basic search page to your website.

Configuring search fields for the Computer page type

First, set up the search options for the Computer page type that you created for the Products section.
1. Open the Page types application.

2. Edit ( # ) the Computer page type.
3. Switch to the Search fields tab.



4. Select the Search is enabled check box.
5. Set the Image field to Computerimage.
6. Click Save.

Product pages are now searchable.

Search is enabled: v
Title field: DocumentMame v
Content field: DocumentContent S
Image field: Computerlmage W
Date field: DocumentCreatedWhen &

Set automatically

Field name Content Searchable Tokenized Custom search name
ComputerlD v

ComputerMame o v

ComputerProcessorType |+ v

ComputerRamSize v

ComputerHddSize v

Computerlmage

Creating a smart search index

Before you can use the search, you need to add a smart search index covering the website's pages.

1. Open the Smart search application.
2. Click New index.
3. Fillin the following details for the search index:
® Display name: My website - Pages
® Index type: Pages
® Analyzer type: Standard
® Stop words: (default)

. Click Save. The index's editing interface opens.

. Open the Indexed content tab and click Add allowed content.

Type /% into the Path field and click Save. This ensures that the index includes all pages on the website.
. Switch to the Sites tab and assign the index to My website.

. Switch to the Cultures tab and choose the default culture of your site (typically English - United States).

. Open the General tab and click Rebuild.
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Once the system rebuilds the index, you can start using it on the website. The Index info section displays the current status of the index and
other relevant information.



General
General
Sites
Display name* My website - Pages
Cultures

Code name:* MyWebsite-Pages [7]
Indexed content

; Index type:™ Pages
Search preview

Analyzer type: Simple v

Batch size:

Preparing the ASPX source files for the search page

. Edit your web project in Visual Studio

. Right-click the CMSTemplates/MySite folder in the Solution Explorer and click Add -> Add New Item.
. Create a Web Form named SearchPage.aspx and check Select master page.

. Click Add and choose the MyMaster.master page from the CMSTemplates/MySite folder.

. Add the following directive to the beginning of the page code:
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<%@ Regi ster src="~/ CMSWebPart s/ Smart Sear ch/ Sear chDi al ogW t hResul ts. ascx"
t agname="Sear chDi al ogW t hResul ts" tagprefix="cns" %

This registers the Smart search dialog with results web part as a user control for use on the ASPX template.

6. Copy the following code inside the <asp:content> element of the page:

<hl1>Sear ch</ hl>

<cns: Sear chDi al ogW t hResul ts | D="Sear chDi al ogWt hResul t s1" runat="server"
Transf ormati onNane="cns. root. snart sear chresul t swi t hi nages"
I ndexes="M/Websi t e- Docunment s" />

This adds a heading and the user control (web part) that provides search functionality and displays the results. The control
uses the My website - Pages search index created in the previous section, which is assigned through the Indexes proper
ty (identified by the index code name).

7. Switch to the code behind of the search page (SearchPage.aspx.cs) and add a reference to the CMS.UIControls namespace:

using CVS. U Controls;

8. Change the class definition so that it inherits from the TemplatePage class:



public partial class CMsSTenpl ates_M/Site_SearchPage : Tenpl at ePage

9. Save the search page files.

Registering the page template

The source files of the search page are ready. Now you need to register the page template in Kentico.

. Switch to the Kentico administration interface in your browser.
. Open the Page templates application.
. Select the My website category.
. Click New template and type Search page into the Template display name field.
. Click Save.
. Set the following values on the General tab:
® Template type: ASPX page
® File name: ~/CMSTemplates/MySite/SearchPage.aspx
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7. Click Save.
8. Switch to the Sites tab and assign the page template to My website.

Adding the search page

. Open the Pages application.
. Select the root of the content tree (My website).

. Click New ( ).

. Choose the Page (menu item) page type.

. Type in Search as the Page name and choose the Use existing page template option. Select the My website category and the Se
arch page template.

. Click Save to create the page.

. Drag the Search page to the end of the content tree.

asrw NP

~N o

To try out the search functionality, view the /Search page in Preview mode. Type PC into the Search for box and click Search.

Our Business, Inc.

Home News Products S5ervices Search

Search results

Search for:

pe |

Search mode:

| Any word v

o=

Home PC Dallas

e /Kentico_8.0_0305/Products/Home-PC-Dallas.aspx 3/7/2014 10:05:04 AM

Office PC Houston

e /Kentico_8.0_0305/Products/Office-PC-Houston aspx  3/7/2014 10:07:04 AM

When you click a search result, the system redirects you to the corresponding page.




Modifying the format of the search results

If you prefer a different design of the search results, you can modify the format by editing the SmartSearchResults (or SmartSear
chResultsWithImages) transformation in Page types -> Root -> Transformations.

Adding a secured section for partners (ASPX)

Kentico provides a way to create secured site sections that can only be viewed by users who have a valid user name and password. This
page describes how to create a logon web page for the purposes of user authentication and registration, as well as a secured page
accessible only by logged in users.

Adding the secured partners page

Start by adding a new secured page that requires authentication. The page reuses the template originally created for the website's Services
page.

. In the Kentico administration interface, open the Pages application.
. Select the root of the content tree (My website).

. Click New ( ).

. Choose the Page (menu item) page type.

Type in Partners as the Page name and choose the Use existing page template option. Select the My website category and the
Left menu with right text page template.

. Click Save to create the page.

. Open the Page tab and type the following text into the editable region: This is a secured page for partners.

. Click Save.

. Open the Properties -> Security tab of the Partners page.

10. Select Yes for the Requires authentication property in the Access section

11. Click Save.
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This ensures that only authenticated (logged in) users can access the page.

Creating the logon page

Build a page where users can sign in to the website and anonymous visitors can register as new users.

Preparing the source files

. Edit your web project in Visual Studio

. Right-click the CMSTemplates/MySite folder in the Solution Explorer and click Add -> Add New ltem.
. Create a Web Form named LogonPage.aspx and check Select master page.

. Click Add and choose the MyMaster.master page from the CMSTemplates/MySite folder.

. Enter the following HTML layout code into the <asp:Content> element on the page:
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<tabl e border="0" style="w dth: 100% >
<tr style="vertical-align: top">
<td styl e="w dth: 50% >
<h2>Log on</h2>
</td>
<td styl e="w dth: 50% >
<h2>Not a menber yet? Sign up now </ h2>
</td>
</tr>
</t abl e>

6. Drag the following web parts (user controls) from the Solution Explorer into the left and right table cells respectively:
®* ~/CMSWebParts/Membership/Logon/LogonForm.ascx
® ~/CMSWebParts/Membership/Registration/RegistrationForm.ascx

7. Set the following properties for the controls:

LogonForm:

Property Value Description



10.

AllowPasswordRetrieval = true Configures the logon form to display a link that allows users to recover
forgotten passwords or generate new ones via email.

SendEmailFrom no-reply@localhost.local =~ Sets the sender address for the password recovery emails.

RegistrationForm:

Property Value Description

EnableUserAfterRegistration = true Configures the control to automatically enable new user accounts after registration.

Switch to the code behind of the logon page (LogonPage.aspx.cs) and add a reference to the CMS.UIControls namespace:

usi ng CMVS. U Controls;

. Change the class definition so that it inherits from the TemplatePage class:

public partial class CMSTenpl ates_MSite_LogonPage

Save the files.

Registering the logon page template
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. Switch to the Kentico administration interface in your browser.
. Open the Page templates application.
. Select the My website category.

Click New template and type Logon page into the Template display name field.

. Click Save.
. Set the following values on the General tab:

® Template type: ASPX page
® File name: ~/CMSTemplates/MySite/LogonPage.aspx

. Click Save.
. Switch to the Sites tab and assign the page template to My website.

Adding the logon page page
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8.

Because you placed the Logon page under a folder, it does not show up in the website's navigation menu. The menu control on the master
page is configured to only display pages of the Page (menu item) type. You can use folders to store pages that have a specific purpose on

. Open the Pages application.
. Select the root of the content tree (My website).

. Click New ( ).
. Choose the Folder page type.
. Type in Special pages as the Page name and click Save.

. Click New ( + ) again and select the Page (menu item) page type.
. Type in Logon as the Page name and choose the Use existing page template option. Select the My website category and the Lo

gon page template.
Click Save to create the page.

the website, but are not part of the regular content.

Setting the website's logon page

Tenpl at ePage

When an anonymous visitor attempts to access a secured page that requires authentication (such as the Partners page on your sample

website), the system redirects them to a logon page. By default, websites use the system page that appears when signing into the Kentico

administration interface. However, you can configure each website to use its own custom logon page.
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5.

. Open the Settings application.

. Select the Security & Membership category in the settings tree.
. Select My website in the Site drop-down menu.

. Clear the Inherit from global settings check box next to the Website logon page URL setting and type in ~/Special-pages/Logon

.aspx. This is the relative URL of the logon page that you added to the website.
Click Save.

The website's logon page is now ready.



Adding a sign out button to the website

The website now allows users to log in, so you should also provide a way to log out. You can do this by adding components to the website's
master page.

1. Open your web project in Visual Studio.
2. Edit the MyMaster.master master page (in the CMSTemplates/MySite folder).
3. Drag the following web parts (user controls) from the ~/CMSWebParts/Membership/Logon/ folder in the Solution Explorer and

place them before the CMSMenu control (inside the <div class="MainMenu"> element):
® SignOutButton.ascx
® CurrentUser.ascx

4. Set the following properties for the controls:

SignOutButton:

Property Value Description
ShowOnlyWhenAuthenticated = true Ensures that master page only displays the sign out button when the site is being
viewed by an authenticated users.
CssClass Right = Sets the name of the CSS class applied to the button.
CurrentUser:
Property Value Description
ShowOnlyWhenAuthenticated = true Ensures that master page only displays the current user information when

the site is being viewed by an authenticated users.

CssClass CurrentUser Right Sets the names of the CSS classes applied to the label.

. Save the changes.

Return to the Kentico administration interface in your browser and open the CSS Stylesheets application.
. Edit the My site stylesheet.

. Add the following class definitions to the stylesheet:
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. Current User
{

color: white;
paddi ng-top: 4px;
}
. Ri ght

{
float: right;

paddi ng-ri ght: 5px;

9. Click Save.

The Sign out button and CurrentUser control are now visible for signed in users on all pages on the website.

Result - Logging in to the website
Now that you have added the logon page, secured section and sign out button to the website, you can test the new functionality from the
perspective of a live site user.

1. Open the user menu on the right of the Kentico administration interface header, and select Sign Out.
2. Click Partners in the main menu. The page is restricted, so the website redirects you to the logon page.



Our Business, Inc.

Home News Partners Products Services Search

Log on Not a member yet? Sign up now!
First name:
Last name:
I E—
() stay logged in on this computer E-mail:
Password:

Forgotten password

Password strength

Confirm password:

Register

This is a sample Kentico website

3. Log on as the administrator again or try registering a new account.

After you sign in successfully, the site automatically redirects you back to the Partners page. Here you can see the content of the secured
page, as well as the name of the current user and the Sign Out button.

Our Business, Inc.

Home News Partners Products ‘Current user: Global Admi

This is & secured page for partners.

This is a sample Kentico website

Kentico also allows you to display content according to the read permissions of users. For example, you can grant the Read
permission for a Gold partners section to members of the Gold partners role, so that only gold partners are able to see the
corresponding menu item and page content.

See Configuring permissions in the main documentation for more information.



https://docs.kentico.com/display/K82/Configuring+permissions
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